Rake error in step 3


#1

I got another rake error in the same step I got in Associations I.

URL
https://www.codecademy.com/courses/learn-rails/lessons/many-to-many/exercises/many-to-many-models-ii?action=resume_content_item

Error

$ rake db:migrate
rake aborted!
Gem::LoadError: You have already activated rake
 12.3.1, but your Gemfile requires rake 10.4.2.
 Prepending `bundle exec` to your command may s
olve this.
/var/lib/gems/2.3.0/gems/bundler-1.16.1/lib/bun
dler/runtime.rb:313:in `check_for_activated_spe
c!'
/var/lib/gems/2.3.0/gems/bundler-1.16.1/lib/bun
dler/runtime.rb:31:in `block in setup'
/var/lib/gems/2.3.0/gems/bundler-1.16.1/lib/bun
dler/runtime.rb:26:in `map'
/var/lib/gems/2.3.0/gems/bundler-1.16.1/lib/bun
dler/runtime.rb:26:in `setup'
/var/lib/gems/2.3.0/gems/bundler-1.16.1/lib/bun
dler.rb:107:in `setup'
/var/lib/gems/2.3.0/gems/bundler-1.16.1/lib/bun
dler/setup.rb:10:in `<top (required)>'
/home/ccuser/workspace/learn-rails-many-to-many
/config/boot.rb:4:in `<top (required)>'
/home/ccuser/workspace/learn-rails-many-to-many
/config/application.rb:1:in `<top (required)>'
/home/ccuser/workspace/learn-rails-many-to-many
/Rakefile:4:in `<top (required)>'
/home/ccuser/.gem/ruby/2.3.0/gems/rake-12.3.1/e
xe/rake:27:in `<top (required)>'

Caused by:
LoadError: cannot load such file -- bundler/set
up
/home/ccuser/workspace/learn-rails-many-to-many
/config/boot.rb:4:in `<top (required)>'
/home/ccuser/workspace/learn-rails-many-to-many
/config/application.rb:1:in `<top (required)>'
/home/ccuser/workspace/learn-rails-many-to-many
/Rakefile:4:in `<top (required)>'
/home/ccuser/.gem/ruby/2.3.0/gems/rake-12.3.1/e
xe/rake:27:in `<top (required)>'
(See full trace by running task with --trace)

#2

Hi @aucontraire,

Does running bundle exec rake db:migrate instead produce an error? (if so, please post it)


#3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.