Python, Miniconda, Jupyter Notebook install

Hello,
I am currently trying to begin the first off-platform project, “Reggie’s Linear Regression”, for the Python3 course, with the first step of the project being to install Python, miniconda, and jupyter notebook. I am having trouble getting the programs to be recognized by the command prompt.
I followed the instructions down to the last letter, yet both the Window’s command prompt and Git Bash only recognize python as a command so when the instructions say to type “Conda list” and “Jupyter Notebook”, they are not being recognized as commands (unlike Python) like the instructions said they should.

Any guidance would be appreciated as I don’t want to mess up the PATH and ruin the recognition of python as well.

Thanks

2 Likes

I also need some help here. I’m in the same spot:

I am 42% complete with Python 3. I’m at the “install python” step. I installed python and then Miniconda/Anaconda3 (latter, then the former). I have two problems - they may be interrelated:

  1. My cmd prompt will not recognize “pip” as a command, and
  2. Probably more importantly (or so it currently appears), my master user profile on my computer is named P&M&M&D. It seems like that is normally not a problem, but when you try to use Anaconda, it is a problem. The CMD.exe Prompt will not load from the navigator and it seems to stumble in the CMD prompt (when opened directly) due to the "&"s in my userid. Do you know the best way to fix this? Thanks!!

It turns out: If your Username has some symbols in it (mine was using “&”) then Python and Anaconda must see that as a command. So, I just created a new user profile with admin privileges and copied all my files from one user to the other, installed Anaconda and it worked.

I originally was going to try to change the user drive path to remove the “&” using some online videos, but I decided the other way was safer in terms of not having to risk a potential massive re-install.

This solution solved both problems above.

I have also not been able to get this to work with the provided download instructions! Has anyone figured this out?

I don’t use miniconda, but i think it has some type of prompt that will allow you to use miniconda’s enviroment that has “jupyter notebook” installed so try :

  1. windows+s
  2. type “miniconda” or “anaconda” or “conda”
  3. if you see some type of prompt select it and use jupyter notebooks there (u can change directory)

You can also install jupyter notebook without miniconda by using “pip install jupyter” tho i recommend doing it after you learn how to create new enviroments just so you dont mess up the base one. In order to create new enviroment you have to go to directory where you want to create it and then type “py -m venv enviroment_name” where enviroment_name can be whatever you want. In order to activate enviroment you must be in directory where you created it and type “source enviroment_name/Scripts/activate” Now you shoul see “(enviroment_name)” in your command line near the field where you type stuff (To deactivate enviroment just type “deactivate”). Then you can install jupyter and other stuff you want. But as I said better google “how to create env in python” and read about it just so you understand what you are doing.

1 Like

Great thank you so much!

Before you replied I ended up installing Juypter with python (rather than trying through miniconda but I might attempt again) using the “pip install juypter”. I did not create a new environment beforehand but I will go ahead and try to do that. I know how to create one with the command line in bit bash so I assume it is something similar.

Thanks again!