Protocols must match error Wanderlust project

I am on step 13 of Wanderlust project

When I submit a city I get this console error:

Blocked a frame with origin “https://www.codecademy.com” from accessing a frame with origin “https://c6073ba55665454a93b2cc7a9714be48.cc-propeller.cloud”. Protocols, domains, and ports must match.

I made some changes in my code based on the Walkthrough including the date in the urlFetch string to today’s date. I checked my code with the Walkthrough.

I am using https in each url in the code.

I searched the forum but can’t find anything related to the above error.

Strange. Has this occurred only once (a fluke), or have you seen it repeatedly like after refreshing your browser?

It happens when I type in a city and click submit. I tried refreshing, same error. I tried logging out and logging back in but the error reappears. The expected url message doesn’t appear.

I quit Safari and restarted it. Now it’s working without the error and it displayed the url message. Thanks for replying.

1 Like

If you can post your code, we can try to help. Click on the </> icon, and then paste your code in the space indicated. This will preserve your formatting, and make your code easier to read. Don’t include your API keys or Client Secret. Those are unique, and belong to you.

EDIT: Just saw your last post. Glad you got it working!:+1:
Also noticed you’re using Safari. You might check this Troubleshooting Guide
Codecademy works best on Chrome or Firefox. There are instructions in the guide for Safari users on checking the necessary plug-ins.
Happy Coding!

1 Like

Very helpful, didn’t know about Safari issues.

1 Like