Problem with Off Platform Project: Baseball

When I try to do the project by importing the files to Postbird, I get this error:

image

This is happening for others as well and is preventing us from doing this project altogether.

Please provide a solution to fix this.

You might have to downgrade your version of Postgres to v.12.
Are you on Windows or Mac?

This thread might be of some help. Scroll down about halfway to a post by neoalexander. PostgreSQL + Postbird 'authentication method 10 not supported'

Or this one:

https://discuss.codecademy.com/t/impossible-to-open-the-baseball-database-off-platform-project-the-best-of-baseball-awards/544546/3

There’s also a YT video which also might be of some help (for Windows):
https://youtu.be/0EBkVzIBnoc

Thanks for the answer but honestly these are just workarounds.
I tried importing the database via pgAdmin and still couldn’t and got errors.

Moreover, the whole project seems to be flawed.
The database is quite huge and confuses a learner who is just starting PostgreSQL and even the hints are misleading. For example, on “PriciestStarter” step, the hint is stating to use the column named “gs” while in the solution, the column with the name of “g” is being used.

I don’t know if these kind of off platform projects are new or what but to me they seem to lack the coherence which other projects have.
Codecademy should first check if the provided functionalities and apps that it requires us to install and operate, work and then make these projects.
It’s a waste of the learner’s time and brings a lot of frustration.

1 Like

Hello, I have had the same issue in Postbird. I have also tried to import into pgAdmin and have been unsuccessfull. It is super frustrating.

1 Like

Update, it is working as of this morning.
First create a database in either pgAdmin or PostBird. Here my database is called test.
Then assuming you have Windows, in command prompt and not Git Bash, type the following:

-U postgres -d yourdatabase < your file path to sql document provided by code academy

For me, this was the code in the line below. Where -U is username for pqsql and d is the database you created and -f is filepath

-U postgres -d test < C:\Users\Alex\Documents\Projects\baseball_database.sql

It will ask for your password if sucessful, if yoy followed the instructions upon download, your password will be postgres
passwords are hidden inside command prompt so you will not see what you type in but after you have typed it, press return.

The bit I missed out was the ’ < ’ between filepath and database as you can see present in my code above.
I did also need to add psql to my filepath on windows, but this may not be neccessary for you. I would try this first.

To add it to your filepath, go to advanced settings in windows, then environment variables, then path in systen variables. I added the following path C:\Program Files\PostgreSQL\13\bin
The path you add depends on where your bin file is inside your PostgreSQL. Note I also have version 13 downloaded. You bin file is probably located in a similar location on your computer and should not be too hard to find. The bin file, i believe, is just the binary code of the computer program.

After doing this, restart command prompt and then repeat the code above inside of it.

Let me know if this works for you.

1 Like

Thanks a lot for the comprehensive answer

I already did the project by downgrading to version 12, but I’ll try to try your solution when I get the chance.

1 Like

It worked for me. Windows 10, Postgres version 14.

The steps I took:

1 - inside Postbird, created a database named ‘baseball

2 - copied the “baseball_database.sql” file provided by Codecademy to C:\Users\Public (this might not be necessary, but I had some trouble trying to import a CSV file another time, and accesing it from Public solved it, so, why not?)

3 - added psql to filepath, as described

4 - from command prompt, cd into C:\Program Files\PostgreSQL\14\bin

5 - from command prompt, added the command psql to the provided line in the answer, so now it would be psql -U postgres -d baseball < C:\Users\Public\baseball_database.sql

6 - it asked me for my pass, so I typed in

Finally, it worked.

I’ll post these steps - and give credit to @code3074961728 - in the assignment thread so it can perhaps help others.

Thank you!

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.