Problem installing sqlite3

Thanks mate, this solved it!

PATRICK THANK YOU! I just wrote an issue about this. Glad I kept searching.

And I encountered such a problem with the sqlite3. I solved it when manually uninstalled sqlite3 and install it again. Only this package.

npm uninstal sqlite3
npm install sqlite3
1 Like

Just verifying that the fix still works (today is 19 Oct 2020). As suggested above I updated the package-json file to list the current version fo sqlite (v5.0.0) and reinstalled sqlite3.

It works fine with the current recommended LST version of NODE.JS (v12.19), so there’s no need to upgrade your NODE.JS to v.14.

Thank you so much Patrick! It worked for me too! Awesome :slight_smile:

Hey y’all! I had the same issue.

I found a solution on GitHub (https://github.com/mapbox/node-sqlite3/issues/612#issuecomment-227239486 and https://github.com/mapbox/node-sqlite3/issues/612#issuecomment-727254701).

In my case, I took the following steps (on a Mac):
1. npm uninstall sqlite3
2. npm --force cache clean
3. sudo npm install sqlite3

I do not recommend downgrading your Node version, as that could have security stability risks.

1 Like

It states on the npm site, https://www.npmjs.com/package/sqlite3, that sqlite3 v5.0.0 is supported by * Node.js v11.x, v12.x, v13.x and v14.x.
So I ended up updating node to v14.15.1 (latest update as of Nov 2020) and then changing the package.json file to read
“sqlite3”: “^5.0.0”,
before running npm install again.
Problem solved.

My joy runneth over:

it worked for me too on mac. did anyone look through the audit at the remaining issues?
im looking now

Thank you Patrick Numbers!

Trying to do this myself with the new 5.0.1 version of sqlite3 but still isn’t working, could you help me out?

npm ERR! code EJSONPARSE
npm ERR! file C:\Users\Arafat\Desktop\test - Copy\package.json
npm ERR! JSON.parse Failed to parse json
npm ERR! JSON.parse Unexpected string in JSON at position 258 while parsing '{
npm ERR! JSON.parse   "name": "pingpongbot",
npm ERR! JSON.parse   "version": '
npm ERR! JSON.parse Failed to parse package.json data.
npm ERR! JSON.parse package.json must be actual JSON, not just JavaScript.

npm ERR! A complete log of this run can be found in:
npm ERR!     C:\Users\Arafat\AppData\Roaming\npm-cache\_logs\2021-01-14T09_08_09_713Z-debug.log

Those were the errors I got and this is what is in the dependencies of the package.json file, bare in mind I typed that sqlite3 line:

"dependencies": {
    "discord.js": "^12.3.1"
    "sqlite3":"^5.0.1"
  }

Have I done something wrong?

Hey there,
maybe its just a simple error, did you try to put a comma between the two lines?

“dependencies”: {
“discord.js”: “^12.3.1”,
“sqlite3”:"^5.0.1"
}