Problem installing Jupyter (Solved)

Hi there,

Having recently started learning Python I have been working my way through the Learn Python 3 course.
I am now at the point I need to create my own workspace on my Windows 10 computer.
Having installed MiniConda i am having difficulty installing Jupyter.
I am being given an error no matter what I try

NotWritableError: The current user does not have permissions to a required path.
path: C:\ProgramData\Miniconda3\conda-meta\history

Any help would be appreciated
I am following these instructions :



try using pip. if you have python 3 (recommended to stay updated) use this command " pip3 install jupyter notebook --user " It’s the --user that allows pip to have the permission to install jupyter. hope that helped!
P.S you may have to install the pip package, when you type in pip3, if it comes up with a “command not found” error… Follow these instructions It is highly recommended to use anaconda installer to install the pip package.
Happy Coding!


This worked!
Had to install pip3 first but then it worked first time.

Thanks for taking the time!


Not a problem! I’ve been there, a lot of stuff you need will be installed through pip. Don’t forget to mark as solved in case someone else has this problem! :smiley:
Happy Coding!

P.S Just as a tip, enter pip3 --help to view all the different commands. Example, I had to install pylint to check my code and it wouldn’t install so i wanted to see if the dependencies were installed, using pip3 --help told me how to check the dependencies and I could figure out what else to do from there. Never forget that --help is your friend! Also, i recommend taking the Command line course. It is super easy and doesn’t take much time. It will give you a better feel for the command line (cmd) just in case you have to use it again…and as an up and coming dev. i’m pretty sure you’ll need that!


I just came on looking for a solution to a problem with pylint and this was actually very helpful.
It has been a day problems.
I am now looking for a solution to:
‘python’ is not recognized as an internal or external command,
operable program or batch file.
I have been working my way through the command line course, and was pretty happy with my progress until todays issues. Hoping to get everything resolved and get back to learning code.

Thanks again.


What is the syntax you are trying to use? If you’re trying to open a python file, and have python >=3.0, use the syntax " $python3 " Specificy if it is python 2 or 3 in your command.

Errors can be extremely discouraging at times and alot of times it ends up being something small, I decided to come on here and see if I could help anyone since the world needs more coders and everyone should get at least some help in whatever form.
EDIT For pylint, use pip3 (if you have python 3) if you don’t have pip it should prompt you to install it. If it doesn’t (and you have it) use the anaconda installer to install pip and then install pylint. If you don’t have it, download anaconda (i think you can download it from their site for window [I’m on linux so i don’t really know about windows with this, i just know the packages]) and then install the rest.
Very happy to help.

1 Like

Thank you so much, spent almost an hour searching for answers and only yours worked!

hello there

could anyone please help me?

while installing jupyter from anaconda i am getting this kind of error

"stderr: ‘chcp’ is not recognized as an internal or external command,
operable program or batch file.
‘chcp’ is not recognized as an internal or external command,
operable program or batch file.
‘chcp’ is not recognized as an internal or external command,
operable program or batch file.’’

return code: 1"

i m literally blocked by that error
please help me

thanks in advance

I tried this solution but it didn’t worked for me. As my operating system is windows 32bit and i want to install jupyter notebook in my pc but i am getting this error :

please help me out.

Just note that the post you’re replying to is from January 2019. A new thread might be a good idea next time since this one is so dated. It might not be the only issue but there’s a line in your error code that states you require Microsoft Visual C++ 14.0. Whilst some errors can be a bit cryptic that’s a good place to start. Link to the download is in the error code too.