Problem - Ctrl + Enter (Run) make the workspace freeze

When I write code in a workspace and click the Save + Run button, everything is ok.
However, if I type Ctrl + Enter, the console doesn’t show anything and I have to refresh the page.

This has been mentioned here before. You might find an answer via search. (I can’t remember what worked for people and what didn’t).

It would also be helpful if you listed:

  • web browser,

  • a link to the lesson that this isn’t working in.

It might narrow it down.

Thank you @lisalisaj.

I was searching and found similar answers but not the one that i’m asking.

1 - My web browser is Chrome.

2 - It’s not a particular lesson. It’s the Workspace where we can test code. For example, The Python Workspace.

3 - When I type Ctrl + Enter (The shorcut for Save + Run), the console doesn’t show anything and I have to refresh the page. If I click Save + Run, everything is Ok.

Ah, okay.
Are you on a Mac or Windows?

Are keyboard shortcuts something that’s default functionality, or is it something that has to be enabled for the workspace? (I’ve not used Workspaces).

I’m on Windows 10.

It’s a default functionality for the workspace. Instead of clicking the “Save + Run” button you type “Ctrl + Enter”. But when I type that, is the problem. For now I’m clicking “Save + Run” but is more confortable for me using the keybord.

Do shortcuts usually work on your keyboard or on other sites?
Is it an external keyboard or the one on a laptop?

1-Outside the workspaces, everything is ok. Maybe it’s a bug.
2-The built in laptop keyboard.

I’m on a Mac and the shortcuts don’t work at all. Plus, I didn’t see them in them under tools.
The “Save & Run” button didn’t work either…

The button only worked when I refreshed the page and clicked the button again.

tbh, I never use the Workspace. I just use Colab for my projects and code snippets.

Update: on around the 6th try, after the page refreshed itself, on its own THEN the cmd + return keyboard shortcut worked. :woman_shrugging:

Here’s a form you can submit (if you haven’t already):

https://help.codecademy.com/hc/en-us/requests/new

1 Like

Yes, maybe the platform has a bug.
Thank you for your help @lisalisaj!

1 Like