Potential bugs on Codecademy-DS path?

So many exercises throw an error, even if you directly copy and paste the code in the solution.

I’ve reported 2 or 3 today alone and now I’ve found that the Frida Khalo Retrospective exercise in Jupyter Notebooks (Data Scientist career paths) isn’t working as it should (yes, I’ve once again copied the code from the solution!).

Not good. Beginning to lose my patience. Perhaps a review on TrustPilot is needed…

Hey!

You’ll have to be a lot more specific with what issues you’re encountering, please share the specific issues along with relevant links and screenshots, without them there’s nothing we can do, and nothing we can report to be fixed.

Hm, I haven’t encountered that. Do you have specific examples so someone can reproduce the said bug?
If you’re reporting a bug…
Things to remember when reporting a bug (anywhere):

  • Be specific. Here, what path or lessons are you referring to (link)?
  • Steps to reproduce this issue?
  • Do you have a screenshot?
  • Web browser you’re using?
  • Are there any extensions installed on said broswer?
  • O/S? (Mac? Windows?)
1 Like

Hi,

I have been specific in the reports I’ve made through the report tool in the lessons.

Hey!

The report tools in lessons are fine, but if you’d like to report them here, where we can pass them directly onto Codecademy then you’ll have to be a lot more specific, and provide the information Lisa listed above, without those there’s nothing we can do other than hear you out.

Complaining about bugs here doesn’t do a lot if we don’t actually know what said bugs are. :slight_smile:

1 Like

Certainly.

For the Frida Kahlo Retrospective Jupyter Notebook off-platform exercise in the Data Scientist career path, you will see a screenshot above of the solution given along with my solution, both of which are exactly the same.

Why is an error thrown after my solution and not the solution given?

Hello!

Thanks for sharing that, what I think is happening here is it is not an issue with the code itself (or a bug) but paintings is defined in another cell further up the notebook, Jupyter notebook is a little strange compared to more “normal” code execution, so you’ll have to run that cell first. Try going from the top and running all the cells sequentially, especially the one where paintings is defined and then run the cell that’s throwing the error.

Happy coding! :slight_smile:

Hi,

I’m afraid that hasn’t sorted it.

I initially coded each cell before running it and so I thought that your solution of running each cell individually before moving on to the next may work, but unfortunately it hasn’t solved the issue.

I see, thanks for checking that, would you mind uploading the entire Jupyter Notebook file to something like a GitHub gist so we can attempt to run the code and troubleshoot it:
https://gist.github.com/

So strange. I have the same code in a Colab notebook and I don’t get any errors.

paintings = ["The Two Fridas", "My Dress Hangs Here", "Tree of Hope", "Self Portrait With Monkeys"]
dates = [1939, 1933, 1946, 1940]

paintings = list(zip(paintings, dates))
print(paintings)

One thing about Jupyter is that sometimes the kernals ‘time out’ and need to be restarted. Did you try that?

Update:
I also tried the same code in a Jupyter notebook and it threw no errors.

Sometimes if you’ve copied the code and then put it in a Jupyter or Colab notebook, the code doesn’t transfer cleanly. What I mean by that is the quotation marks are not valid, so to speak, in Jupyter or Colab and you need to retype them.

OK, thanks.

I’ll give it a try later. I’m just going to take a break from it for now as I’ve recognised that I’ve got a little stressed with it :slight_smile:

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.