[potential bug] Codecademy in Microsoft Edge

Anyone else using Codecademy in Microsoft Edge and get a strange bug? Whenever I move on to the next step in a lesson the default code given doesn’t change so I can’t progress.

Works fine in Chrome. I know, “use Chrome”, but honestly I haven’t had a problem with Microsoft Edge so far and I think it isn’t a bad browser. Just wondering if this is a known issue.

1 Like

I also encounter this problem when using Edge, but it also happens in Chrome and Firefox sometimes (less than in Edge). Non-scientific assessment: It seems to happen more often when I have a slow connection, like when I’m on public WiFi.

Hey Larry, at time of writing we do support Microsoft Edge, but we recommend Google Chrome and Codecademy is optimized most heavily for Google Chrome. That’s the norm for a great many sites across the web, and it’s not as much down to Edge being a “bad browser” so much as making sure that the experience is optimized for the majority of users.

If you feel that you have found a bug or performance issue, consider reporting it!

Has this been fixed, its two years since it was reported. Cannot pass the second page of the JavaScript basic course and I use chrome for work. Now as Chrome and Edge use the same background codex, I guessed it would just work. Trying the basic to see if its worth me going down this route with the paid option or taking the original route I’ve always taken by trial and error on a server with space for the same money per month!

Here’s the code below

// print number 5

Which works and shows 5 on the second frame, however the “next” option is greyed out and the script error pops up asking " Did you use console.log() to print the number of weeks you’ve been programming to the console?"

Any ideas?

Cheers in advance

Let me ask around:

Just to be sure, you put


but did you try:



The validator may be being strict about whether it’s a string or an integer.

Yeah, tried it both ways and it still showed number 5 in the parallel frame to the right once run had been selected, yet the coding frame showed the same error on both accounts

Sounds like a bug then. Let’s see if we can report it…

I can’t re-create this issue, using the latest build of Edge (based on Chromium).

Can you try resetting the exercise, and try again? :slight_smile:

Yeah, reset it a few times. It’s the latest edge. All the software is bang up to date to

Cheers everyone for looking