PostgreSQL + Postbird 'authentication method 10 not supported'

Thank a lot. This Solved. :slight_smile:

THANKS!! This resolved the issue!

Wonderful solution!
Piece of advise to those who like me did it for the first time, remove the full “scram-sha-256” for “trust” just as posted

This helped me solve my problem, thank you so much for taking the time to share with us and help!

THANK YOU! I was struggling with this for such a long time.

This has STILL not been fixed (Jan 2023). Thank you for your solution. I don’t really understand what you did, but it worked!

This didn’t work for me :frowning: pgAdmin4 doesn’t accept my password when I add trust

1 Like

It didn’t work for me anything at all((

I’m getting really, really, REALLY tired of having to go through these extensive troubleshooting guides for LITERALLY EVERY PROJECT I’ve encountered off-platform on the Fullstack course

Is it really so hard - on a paid service - to just update your damned starter code to work with current versions of software, given that any kind of software development is a fast-moving world of updated and iterated versions of everything?

How is a learner - who by the very fact that they’re taking a course is likely to be very unfamiliar with virtually everything being used - supposed to have a clue what most instructions and search results are even saying, assuming they can even articulate their issue eloquently enough in the first place to even ask the right questions through Google?

For goodness sake Codecademy, sort your ■■■■ out for once and stop relying on kind strangers in forums to keep your material halfway usable

Not impressed at all

7 Likes

Thanks amigo o7. Very helpful indeed

After 2 hours found this solution that actually worked. Thank you.

You have no idea how many hours you saved me! thanks man!

This worked for me too. Thank you! :o)

This worked! Thank you very much!

And this comment is really pertinent:

1 Like

Perfect solution. Many thanks

This works!

However it’s not clear where to find this file. I found it by watching the video in the comment user: system88… replied to.

It’s in Program files/PostgreSQL/[version number]/data. For me the version is 15

Thank you so much for these instructions! I was able to finally get my .sql file imported with no issues.

Dec 2023 and I can confirm this fix still works

This also fixed the import issues for me. Thank you :slight_smile:

This took me absolutely forever to work out. By putting together lot’s of different things, here is how I did it:

  1. Open Postbird and create the database ‘baseball’ as instructed.
  2. Add “C:\Program Files\PostgreSQL\16\bin” to ‘filepath’, through System Properties → Advanced → Environment Variables → User Variables → New → Name: filepath, & browse for bin location.
  3. Move the file to “C:\Users\Public\Coding Files\baseball_database.sql” (‘Coding Files’ folder unnecessary, but helped me keep organised).
  4. Open Command Prompt
  5. enter: cd C:\Program Files\PostgreSQL\16\bin
  6. enter: C:\Program Files\PostgreSQL\16\bin>psql -U postgres -d baseball
  7. enter password for user postgres: postgres (note: commandprompt will not show the text you enter, put it is being registered. Use enter to submit)
  8. enter: C:/Users/Public/Coding: No such file or directory
    baseball-# \i ‘C:/Users/Public/Coding Files/baseball_database.sql’ (It is absolutely essential you get this one right with the direction of the slashes and the use of single speech marks. Anything else and it will give error messages).
  9. It should show it all adding it to the database on commandprompt
  10. Return to Postbird and it should be there!