PostgreSQL + Postbird 'authentication method 10 not supported'

I have not attempted this particular course yet so I’m not sure how much help I could be. (I’ve also only used PgAdmin as a GUI w/PostgreSQL).

If you’ve googled the error messages and determined that you should change your pw authentication settings, then I suggest trying it. (you can always change it back if it doesn’t work).
I found this:

And the PostgreSQL documentation on authentication methods might help:


Hello Lisa,

just tried that and still does not work… When I try to export the database I get this message

It says that it saved the file but I find no file. However, though I am not sure this is related, when I open pgAdmin I see the same databases created with Postbird and from there I can export the tables I created.

In a way or another, I manage to do what I need to for now but I still wonder what is wrong…

1 Like

I have the exact same errors. Since I’ve just started exploring PostgreSQL, I don’t exactly know what the info tab does. However, not able to import/export a .sql file onto Postbird is a bummer:)

1 Like

Hi Marina!

Had the same issue here. I fixed it by downgrading to PostgreSQL version 12.

I’m sure you’ve fixed it by now, just writing it for posterity.

1 Like

This post was first open in Dec 2020.
I joined amonth ago (May 2021) and cannot find a suitable solution to this problem.
I already uninstalled/re-installed postbird/postgres, used different versions and can’t use that baseball database at all.

After looking into other forum topics for the same issue, I see no clear answer on how to resolve this “method 10 is not supported”.

Has anyone found a clear solution ?

1 Like

So after quite a few hours spent looking for a solution, here’s how I solved it :slight_smile:

  1. Followed instructions in this video : ‘psql’ is not recognized as an internal or external command
  2. Followed @davbyron thread and replaced required fields + path : psql -U postgres -d baseball -f C:\Users\alexa\baseball_database.sql. More details in the original post Querying Baseball data off platform project - #40 by neoalexandre

open the file pg_hba.conf and in the end of the file, put “trust” value in METHOD


“local” is for Unix domain socket connections only

local all all trust

IPv4 local connections:

host all all trust

IPv6 local connections:

host all all ::1/128 trust

Allow replication connections from localhost, by a user with the

replication privilege.

local replication all trust
host replication all trust
host replication all ::1/128 trust


Thanks for your help. This solves the issue.

1 Like

Hello, I had issues importing the data.

I downgraded from version 13.0 to 12.7.

1 Like

I’m curious as to what consequences these changes might have (I’ll see if I can figure it out in the documentation), but this is the first solution that worked for me! Thanks!

Note: I had not yet conceded to installing PostgreSQL 12, but that was my next step.

1 Like

I have the same problem. I cannot import .sql files, and I cannot export .sql files because

1 Like

I also had this issue. What I did was installing the listed alternative, pgAdmin 4, to export my Postgres database.
Although the interface is more cluttered, you just have to right click on database and chose “Backup” and “Restore”.

I think this is an easy work-around.


This solved the “authentication method 10 not supported” error.

Now I have an issue of mismatched pg_dump - postgres server version

1 Like

I had the same problem.
I downgraded postgreSQL to 12.9, keeping the Postbird the same and the issue was solved.

amazing - thank you so much!!!

Worked for me too! <3

Excellent info.


Import was a success after making these changes. Thank you!

I’m on Postgres 14.

Thanks a lot, the import worked!

Thank a lot. This Solved. :slight_smile: