Pipenv not working in the same way

hello, i cant create virtual environment like in the video in the python3 course. Instead it creates in a different path than the project-1 like in the video, what should i do?

Do you have a link to the guidance for this lesson? A little more information about the commands you used and the output you got might be necessary to give others the best chance of offering useful advice.

https://www.codecademy.com/courses/learn-python-3/videos/learn-python3-pipenv
This is the video im talking about. Im following the steps in the video, but the pipenv --three is not working the same way. It does create the environment, but not in the folder I want, but in my user profile

It should create the pipfile in your current working directory. Try removing the pipfile from your home directory, navigating to the correct project folder using cd (important step) and re-running the pipenv commands.

fecot@DESKTOP-N21A90K MINGW64 ~/Desktop/project-1
$ pipenv --three
Creating a virtualenv for this project…
Pipfile: C:\Users\fecot\Pipfile
Using C:/Users/fecot/AppData/Local/Programs/Python/Python38/python.exe (3.8.7) to create virtualenv…
[ =] Creating virtual environment…created virtual environment CPython3.8.7.final.0-64 in 3235ms
creator CPython3Windows(dest=C:\Users\fecot.virtualenvs\fecot-cSSQOZRX, clear=False, no_vcs_ignore=False, global=False)
seeder FromAppData(download=False, pip=bundle, setuptools=bundle, wheel=bundle, via=copy, app_data_dir=C:\Users\fecot\AppData\Local\pypa\virtualenv)
added seed packages: pip==21.0.1, setuptools==52.0.0, wheel==0.36.2
activators BashActivator,BatchActivator,FishActivator,PowerShellActivator,PythonActivator,XonshActivator

Successfully created virtual environment!
Virtualenv location: C:\Users\fecot.virtualenvs\fecot-cSSQOZRX

fecot@DESKTOP-N21A90K MINGW64 ~/Desktop/project-1
$

Here is the terminal.
im in the \desktop\project-1 folder, but it creates the virtual environment in the fecot.virtualenvs folder.
I tried to delete the virtualenvs folder, but nothing, tried to remove the pipfile but nothing(maybe deleted the wrong one)

Okay im kinda â– â– â– â– â– â– â– â– , when I read back the terminal, I found which pipfile I need to delete.
Its working now, thanks for the help :).

1 Like