Pig Latin: Error nueva_palabra no es correcto


#1

Resulta que estoy resolviendo el siguiente ejercicio, sin embargo, a pesar de que el resultado sea correcto, no me deja avanzar indicando que el valor de: nueva_palabra es incorrecto, sin embargo desde la consola puedo ver que el resultado es el debido... cual es el problema=? :rage:

pyg = 'ei'

original = raw_input('Escribe una palabra:')
if len(original) > 0 and original.isalpha():
    palabra = original.lower()
    if palabra[0]=="a" or palabra[0]=="e" or palabra[0]=="i" or palabra[0]=="o" or palabra[0]=="u":
        nueva_palabra = palabra + pyg
        print nueva_palabra
    else:
        palabra3 = palabra[1:]
        nueva_palabra = palabra3 + pyg
        print nueva_palabra
else:
	print 'Vacio'

Ehh aqui el resultado del codigo:

Escribe una palabra: Hola
olaei
None

#2

Finalmente, pase a la siguiente sección y el código final quedo asi:

print "Bienvenido al traductor de Espanol a Pig latin"
pyg = 'ei'

original = raw_input('Escribe una palabra:')
if len(original) > 0 and original.isalpha():
    palabra = original.lower()
    if palabra[0]=="a" or palabra[0]=="e" or palabra[0]=="i" or palabra[0]=="o" or palabra[0]=="u":
        nueva_palabra = palabra + pyg
        print nueva_palabra
        print "\n La palabra original empezaba con una vocal"
    else:
        palabra3 = palabra[1:]
        nueva_palabra = palabra3 + pyg
        print nueva_palabra
        print "\n La palabra original empezaba con una consonante"
else:
	print 'Vacio'

En la consola sale lo siguiente

Bienvenido al traductor de Espanol a Pig latin
Escribe una palabra: Hola
olaei

 La palabra original empezaba con una consonante
None

Ya probé este código y no tiene errores es totalmente funcional, sin embargo cada vez que vuelvo al paso 11, sigue marcando el mismo error...


#3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.