PHPMyAdmin Error #1558 plus 'no such directory' + 'command not found' on Mac Terminal

Context: I am learning Stored Procedures with the help of PHPmyAdmin as a school project. Since yesterday I have been fighting the annoying error #1558.

The exact error is as follows: Column count of mysql.proc is wrong. Expected 21, found 20. Created with MariaDB 100145, now running 100415. Please use mysql_upgrade to fix this error

This error pops up whenever I tried to set a stored procedure via the ‘Routine’ function or write a procedure query directly on the SQL field via the ‘SQL’ function. The query I tried to enter was just error-free as all my other teammates have no problem generating the result we wanted. They have had no 1558 error either. FYI I am the lone Mac user and all the others are Windows users. According to this website, the error seems to be a unique one to the MacOs. What do you all think about that?

In the meantime, I have been searching StackOverFlow and other sites and trying out commands but it led me to another problem: every time I enter all those commands into my Mac Terminal it gives me no such directory exists or ‘command not found’ like the one pictured below:


I am pretty sure I am missing a basic in resolving the command errors. I appreciate any inputs or advice.

Did you see this by any chance?

" You should run mysql_upgrade after upgrading from one major MySQL/MariaDB release to another,"

Hello lisalisaj! Thank you for the response. I have an extra noob question. I checked the link you sent me, but I am stuck with upgrading MYSQL/MariaDB to the latest one.


As per screenshot, I am on upgrade mariaDB 4.0 to 5.0 as my current MariaDB is 10.4.10 which is connected to PHPmyAdmin.
I am a bit stunned to see that I must have Linix distributions to go ahead with the upgrade. I am a MacOS user and I installed XAMPP and PHPmyAdmin to set up the SQL database. I am not sure if I am on the right path.

Appreciate any hints again.

I am not familiar with this at all so I’d also have to read through the documentation too.
This doesn’t seem to be the correct page for upgrading b/c it applies to Linux-based systems.

One thing I do know before you upgrade anything: back up your DBs. :slight_smile:

Perhaps @coffeencake has some insights here? :grinning:

Hello @awkwineh183 ,

I will try to offer some words of wisdom but I haven’t installed MariaDB before and/or on a MacOS. :grinning_face_with_smiling_eyes:

  1. confirm that mysql_upgrade file exists in the directory
  2. confirm that /opt/lampp/bin also exists
  3. If those files are not there, you mentioned there were Linux distributions possibly missing.
  1. Sometimes it is easier to just do a install of the newer version instead of running an upgrade. However, make sure you have a backup before you start.

Sorry, I hope that helps a little.

2 Likes

Hi! Thank you for the tips coffeencake.

Regarding the 3. point “If those files are not there, you mentioned there were Linux distributions possibly missing.”

Does this mean that I need to install Linux on my Mac? Sorry for this noob question.

I don’t think you need to install Linux. I would try the other couple solutions from your link.

2 Likes