PHP form on github gone wrong

I made a github repository with HTML and PHP:

What I was trying to do was use a w3 example of PHP and see if it worked.
When I submitted the form, github would throw an error saying “405 not allowed”. Can you please explain why this happens and possibly what I had done wrong?

I don’t think you can create submittable forms with a GitHub domain. That would give you indirect access to GitHub's server, and that’s all any competent hacker needs.

1 Like

Yep, that’s not going to work on GitHub.

If you want to practice your PHP, one option would be to download XAMPP:

It’s a pretty good environment to code PHP locally.

Another option is MAMP. Or, you could set up a LAMP server on your computer, but that’s a little bit more advanced and I wouldn’t particularly recommend this at this point.

1 Like

That does make sense. So do I have to get my own custom domain name to do that?

Okay. I’ll try that.

You can get a certain country-codes for free, but the domain suffix will be some unpopular country code (.tk if you get it at ) AND the suffix will SERIOUSLY mess up your SEO since modern browsers don’t recognise such suffixes so easily.

So if you want your site to be popular paying for a good domain is the only way. Also, note that if you use a WYSIWYG(What You See Is What You Get) website builder like Wix or Weebly what you will actually get is a sub-domain like or

Thanks you both for helping me out.

Thanks for the info.
the XAMPP didn’t download properly and I couldn’t use it.
I tried MAMP but I couldn’t figure out how to use it.

Thanks for all the help. I will put this knowldege to use.