[PENDING] $expect is not defined

Hi, i need help. When a write a CSS code, i get an error that says “$expect is not defined”
here is my link: https://www.codecademy.com/paths/web-development/tracks/styling-a-website/modules/learn-css-selectors-visual-rules/lessons/css-setup-selectors/exercises/classes-and-ids

Hello @dalisum, could you please post your code, because when I follow that link, I just get my code.

hello. here is the assessment:

In style.css , set the font-size of paragraph elements to 18 pixels:

p {
color: AliceBlue;
line-height: 1.3em;
text-align: left;
width: 100%;
font-family: Helvetica;
font-size: 18px;
}

As you can tell, I have set the font-size to 18px. But i keep on getting an error saying “$expect is not defined”. please help. thank you.

Hi! I’m facing the same issue on https://www.codecademy.com/paths/web-development/tracks/getting-more-advanced-with-design/modules/learn-css-box-model/lessons/box-model-intro/exercises/box-padding-i when trying to parse my CSS code. Worked fine for the first excercise but keeps coming back when I restart the lesson. I even restarted firefox but the problem persisted. Tried it now using Chrome and my exact same code was accepted as correct.

Seems to me to be a bug in how codecademy’s code is being read by firefox. Would love to one day understand and be able to debug these problems

Hello @blog2899083552 and @dalisum, do you think this is a bug with the system? Personally, I haven’t experienced it, but if you think it is, I can raise a ticket for you.

Hi @codeneutrino, I tried it again this morning and the same problem persists in firefox but not in chrome. I’ve disabled all ad- & script-blockers and the problem persisted. Is there any way I could provide more info? Perhaps a ticket could be a good way to determine whether it’s codecademy or some change in firefox.

Ok, I’ll raise it with the CC moderators, and see whether they think it is a good idea to report it. I hope in the meantime, you find a way to get around it (you said it was only a problem on Firefox?). Happy coding!

Edit: I’ve moved it to the bug reporting category.

Hey there!

@codeneutrino has flagged this up.

Leave it with me and I’ll see if I can recreate the problem. :slight_smile:

1 Like

I just continued the course on my laptop which didn’t throw this error even though I’m also using firefox on my laptop. Is there any information I could provide that could help you?

Hi everyone.

Thanks for waiting.

I’ve tried to replicate the problem on my computer, also using Firefox, but I can’t seem to recreate the problem.

I suspect that what you’re seeing is related to how the environment is testing your submissions, but that’s just a guess…

@dalisum and @blog2899083552, is the problem still occuring for you? :slight_smile:

Hi everyone. The problem did persist. in order to finish the CCS assessment, I had to go to the solution on some parts. I will be doing java script soon, so I will let you know if the problem persists. Thanks everyone for your input.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.