[PENDING] Deploy website in Github

Hi, evrybody. I am learning the course:

https://www.codecademy.com/courses/deploy-a-website/lessons/github-pages/exercises/add-remote

And I have run into a problem. No matter which command I try, the browser just gives me an error.

Can someone help?

You will first need to create a local git repository:

git init

@stetim94
I tryed that:

But you get a different error now? So you are a step further.

now it says: remote origin already existed. So you have already completed this :slight_smile:

@stetim94
Yes, I should have completed this, but codecademy doesn’t give me the check:

you remove the remote:

git remote remove origin

or something like that, and try again.

1 Like

I tryed that also:

you are sure that remove works too? The hint says to use rm (i do not know these commands from the top of my head, that is why documentation exists)

you could verify no remote has been setup using:

git remote -v

have pressed enter after typing the command? I would expect to see a new $ at the next line.

@stetim94
I did get a $

@stetim94 ?
Are you there?

you have walked through all the steps now, it seems. Not sure what else the problem can be. There now doesn’t seem to be a remote, so now adding a remote should go fine.

otherwise, you should make a bug report.

@stetim94
So I do a bug report?

I think that is a good idea.

Hey both.

@renbozhang can you please check the output of the pwd command in the terminal? I am expecting that you’ll get this:

$ pwd
/home/ccuser/workspace/daw

The reason that you’re unable to complete the git remote add origin command is because the daw directory is not a Git repository.

Exercise #3 (Initialize Your Repo) has you change into the personal-website directory and initialize a repo there (with git init), however this does not appear to persist when you move to Exercise #4 (Add the Remote).

If you cd into the personal-website directory, and then try and add the remote, everything should work (presuming that you correctly initialized it as a repo in the previous exercise).

(I’m also going to move this to the Bug Reporting category, and will log it with CC.)

1 Like

@thepitycoder
This is what I get:


I still get a cross instead of a check.

doing cd without any arguments will take your to your home directory. Which means you are not in the right directory to complete the exercise. You should be in your personal-website directory as pointed out by @thepitycoder

1 Like

Thanks @thepitycoder. It worked!

1 Like