Pages_controller.rb not in folder

So how do we solve it and get to the next exercise?

1 Like

@vallkan There’s no reliable easy way that I’m aware of. If you wait, I’m sure the staff will have it fixed soon, though.

1 Like

I finally figured it out. If you go to #2 and add these into the GEMFILE (code editor)
‘tzinfo’
‘tzinfo-data’

then bundle install and go to #3

On #3 step 1
refresh the page
do step 1 again and then do step 2 you can then move forward.

6 Likes

what do you mean? where should I add it?
should I add “gem ‘tzinfo’” or should I just add ‘tzinfo’?

What do you mean go to #2 and #3? None of the steps in the Rails lesson seem to be working. Reading online it seems like it’s a version issue, but I tried updating and that didn’t help either.

For clarification, because I did not understand what cpumplun was trying to say either, here’s another phrasing of the solution.

Before generating the controller (Excercise 3. Controller), navigate to the text file Gemfile. Scroll to the bottom of the document, and paste these two lines of code at the bottom:

gem ‘tzinfo’
gem ‘tzinfo-data’

Save Gemfile (I had to hit Run instead of save, but it’s the same functionally).

Once saved, in the Bash terminal type: bundle install

Finally, Do step 1 of the exercise, which is, in terminal, type: rails generate controller Pages.

You should now have a pages_controller file.

By the way, I had to repeat these steps for the next lesson Broadway to get it to work there too, so might be worth just adding it to the workflow.

17 Likes

Really thank you. :grin:

1 Like

Thanks That’s Awesome

1 Like

Thanks for this, I referred to hurstonp 's method to do it bit by bit, but thanks for this original post too :smiley:

1 Like

BTW You can also use vim in the bash terminal to edit the Gemfile:

$ vim Gemfile

This also works.

Also I’d suggest to specify the version of tzinfo-data like so:

gem 'tzinfo-data', '~> 1.2017', '>= 1.2017.2'

Thanks!

2 Likes

I have followed all the steps that hurstonp suggested, including the addition that al3nmicl identified, but even though the bash indicated that pages_controller was created, I cannot find it in the Controllers folder.

1 Like

Nevermind! Refreshing the page is always worth the try :smiley:

2 Likes

Actually, I had to edit via the terminal as well as the Gemfile wasn’t showing up in the GUI. I used Nano, but same thing. The version info is a good point. Thanks for adding to the solution.

Has this issue really not been addressed by staff after 3 weeks? Should I hold off on a Pro membership?

1 Like

Yes, I think you should hold off on a Pro membership. It is absolutely ridiculous that we should be manually editing a gem-file at this stage - and that we should be finding those instructions on a forum.

If you have money to pay for a pro something, go with Treehouse or Pragmatic Studio.

1 Like

Help me a lot, thank you!

Thanks for this, it worked for me!! :grinning:

Issue still prevalent a month later…

cpumplun’s solution is required to continue.

2 Likes

Thank you for this solution!

Guess what… , my Gemfile got reset. So I had to redo the tzinfo line again. :frowning:
I wish Cc maintainers would figure out a way to allow it’s users to backup their environments to something like cloud 9 IDE.

Or perhaps letting us use the IDE to do the exercises as an optional environment. I would pay PRO subs for that.