Pages controller doesn't appear after being generated


#1

I run the command to generate the controller and it seems to finish correctly, but the Pages controller simply does not appear in the file explorer on the side. How do I fix this?

The Pages folder is created the Views folder, but no controller. I tried creating a controller manually and it brings back this error when i try to run the tests:

"Oops! The test returned an error. Maybe you have a syntax error, or a typo. Hide error.
/home/ccuser/.gem/ruby/2.3.0/gems/activesupport-4.1.1/lib/active_support/values/time_zone.rb:285: warning: circular argument reference - now
"


Browser not working
#2

Hi @zewp,

Could you please post a link to the exercise and a screenshot of the issue. I'd like to take a look, but I'm not sure what the problem is.

In the meantime, I'd suggest refreshing the page or switching browsers.


#3

I'm getting the same issue, it seems to be after step 1 in "3.Controller"

https://www.codecademy.com/courses/learn-rails/lessons/start/exercises/start-controller-i?action=lesson_resume

The "rails generate controller Pages" command fails, spits out a long error beginning with,

/home/ccuser/.gem/ruby/2.3.0/gems/activesupport-4.1.1/lib/active_support/values/time_zone.rb:285: warning: circular argument reference - now

/home/ccuser/.gem/ruby/2.3.0/gems/tzinfo-1.2.2/lib/tzinfo/data_source.rb:182:in `rescue in create_default_data_source': No source of
timezone data could be found. (TZInfo::DataSourceNotFound)

In addition, I've tried reloading, and installed Firefox specifically to test this. Same issue across browsers/sessions

Hope that helps.


#4

Hey @zystvan, I see jbcrotinger posted the link to the exercise. Here's a screenshot of the specific error. It seems to happen across browser for me too. I notice that when typing in the terminal there is also very noticeable input delay when typing. I'm not sure if it's related.


#5

Thanks for the link and screenshots! I reported that error for someone else just yesterday, but I'd suggest you each do the same. You can file a bug in the form beneath the instructions on the left.

And after that, the only thing I can suggest is that you wait a day or two. Sorry for the inconvenience :confused:


#6

I got the same error . Let me know if there is any resolution


#7

There is a solution to the DataSourceNotFound error: adding a line to the Gemfile "gem 'tzinfo-data'" and running 'bundle install' solves the problem. The only thing is that the change in the Gemfile doesn't seem to be permanent, so when you log in again you may have to do it again.


6. Show a destination 6/9 - destinations controller is not generating
#8

One of the advisors told me to add both

gem 'tzinfo-data'
gem 'tzinfo'

in the gemfile, then run click run to save, and execute bundle install from the command prompt. Seems like you have to do the bundle install again after logging in, but the gemfile got saved in my environment


#9

I have the same error, putting tzinfo-data and tzinfo in the gemfile indeed helped. This is clearly an error in the codecademy environment.


#10

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.