Oops, try again. Did you set the first paragraph's font-size to 10px? It looks like it's 12px. (If you're getting a weird decimal font size, check the Hint.)

< p>tags :dizzy_face:

This is a browser issue, your browser has a minimum font-size, do a google search: disable minimum font-size chrome

@luokun0725,

Last, but not least, you could try this:

<p><font size="12"> Blah Blah Blah </font></p>

Or maybe it’s - as @stetim94 said - a browser issue…

please don’t try this, <font> has been out of service for ages. The problem is simple the browser preventing font-size from going below 12px. you can also add this to your code:

<style>
* {
    -webkit-text-size-adjust: none;
}
</style>

that should prevent the browser from applying the minimum font-size setting

1 Like

godness,so cool,i got it.

1 Like

but which tags should THIS be contained?

you can either change the minimum font-size setting in the browser setting, or add the code i showed above, which should be inside of <head></head>

Finally.

Good to know, @stetim94! :slight_smile:

default font-size of paragraphs: 16px. If you ever see this error message again (paragraph is 12px instead of 10px), you now know what the problem is :slight_smile: And how to fix it :smiley:

Hey @luokun0725, you are missing something small but important, everybody forgets them every once in a while :slight_smile: It is basically the period of css. It is like a colon only it is semi; you guessed it, a semicolon, you are missing it right before each and every “sentence” of your css. Hope this helped :slight_smile: you will get more use to remembering them as you progress, but you will still keep on forgetting them every once in while like everybody else does. And if that doesn’t work, then it is definitely what @stetim94 said, it is the browser. If so, then I would suggest something like Safari(which I use) or FireFox.

semi-colons aren’t required for a single property + value or the last property + value. I agree with that you should use them for consistency, but that is it

Right, I am use to trying to write clean code, and by force of habit use semicolons after every css property (I am so glad that Swift doesn’t use semicolons). But the link would also be helpful to give me more of an idea of what is wrong with his code (if anything). You could be right though, it might just be his browser. + I didn’t know that :slight_smile:

True, but then it would be nice to indicate in your answer that this has to do with clean code, not the error message

Well, since the default font-size of a paragraph is 16px, and it is changing to 12px it indicates the font-size is changing, so it very likely that a browser setting is blocking you

1 Like

You are right of course, or out of the least likely of all the options, it could be a bug on Codecademy.

It could be, but i have seen this error many times before, people either solved it by disabling the minimum font-size or switching to a browser without minimum font-size setting.

I never thought about minimum font-size before. That could be a pretty good explanation of why the code isn’t working though.

you know what,I passed by adjusting the size of the whole page.However,I wrote down the codes that you give me which didn’t work and i don’t know why…

This seems like a completely different exercise?

no ,expect the picture…and it seems that the codes
< style>

  • {
    -webkit-text-size-adjust: none;
    }
    < /style>
    didn’t work…

on Chrome

and my replies are limited,is everyone’s replies limited?sometimes i have to reply after 24 hours.