Oops, try again. Did you set the first paragraph's font-size to 10px? It looks like it's 12px. (If you're getting a weird decimal font size, check the Hint.)

<PLEASE USE THE FOLLOWING TEMPLATE TO HELP YOU CREATE A GREAT POST!>

<Below this line, add a link to the EXACT exercise that you are stuck at.>

<In what way does your code behave incorrectly? Include ALL error messages.>

``` First font size change

Some text for you to make tiny!

Some text for you to make normal size!

Some text for you to make super big!

<do not remove the three backticks above>
1 Like

Hello @luokun0725,
Your code seems correct to me.

Did you try refreshing the site with Ctrl+R or (Ctrl+)F5?
And then compiling the code again.

I‘ve tried many times!
It just can not pass…

Hmm, that is really weird.
Did you try it with semicolons?

So that your formats look like <p style="font-size:10px;"> etc for 20px and 40px aswell?
(Fyi: a semicolon after px)

Hope that this will help :slight_smile:

Maybe try ctrl + shift + del, this will give you the option to clear your cookies and cache… that might work, if not it’s still a cool shortcut :slight_smile:

I take it clearing cookies and cache didn’t work :slight_smile:

Hmm… what happens if you add an important to that style?

<p style="font-size:10px !important"> Some text for you to make tiny! </p>

@rorygrenade - I guess that’s a bit too far for such a “basic” HTML-course…

Never seen an error like this :open_mouth:

@luokun0725 Did you try to try to change browser

Still not work…
I’ve tried clearing cookies and write the code again…

It would be interesting what the Hint says

Maybe, but would be interesting to see what happens. Disclaimer (for green HTML coders) - Only use !important if you have no other choice :slight_smile:

Still not work by using “!important”…

Next step would be packing it into a <?php ?> … something like

<?php echo "<p style='font-size:10px !important'> Some text for you to make tiny! </p>" or die(); ?>

:joy::joy::joy::joy::joy:

@luokun0725,

Hmm, try using simple 's instead of double "s - maybe THIS will work.

Try adding this a style tag with a really specific selector like so:

<style>
    p:first-of-type {
        font-size: 10px !important;
    }
</style>

^ @luokun0725: you have to put this - if you didn’t learn it so far - in the <head> ... </head>of your file.

Still not work… :confounded:

It tells me that I should have 3

tags…