Oops! 26. Links and text decoration


#1

https://www.codecademy.com/en/courses/web-beginner-en-TlhFi/4/5?curriculum_id=50579fb998b470000202dc8b

Hi

So, I've been on this for about ten minutes now and I'm near going crazy.
I'm pretty sure I wrote the code right but yet, it's still says "Oops, try again. Did you remember to set your link's text decoration to none ?"

a {
    color: #cc0000;
    text-decoration: none;
}

Now, I'm quite the type to make careless mistakes so at first I was like, yeah probably not, but I've been glaring at this thing for loads of minutes now and I can't see anything wrong with it. I've tried to refresh the page, delete that part, rewrite, change the order between text- decoration and color (you never know) and still, NOTHING. I even looked at a previous exercise I had done wich involved those same attributes and values and it's the EXACT SAME.

Am I right, is that particular exercise not working for some mysterious reason that may involve witchcraft or am I just missing something here ?

Thanks in advance and please help ! :sob:


#2

Perhaps you forget to link the css...

<head>
    <link rel="stylesheet" type="text/css" href="stylesheet.css">
</head>

#3

can we see your full html and css code?


#4

So here is the HTML :

<!DOCTYPE html>
<html>
	<head>
		<title>Result</title>
		<link type="text/css" rel="stylesheet" href="stylesheet.css"/>
	</head>
	<body>
	    <h1>Yo this is a Test</h1>
	     <p>Yup, just an other test again</p>
	      <img src="https://rushingjaws.files.wordpress.com/2015/01/new-picture-1.png"/>
	      <a href="http://codeacademy.com">Learn with me</a>
	</body>
</html>

And here is the CSS :

h1 {
    font-family: Verdana, sans-serif;
    color: #576D94;
}
    
p {
    font-size: 18px;
    color: #4A4943
    font-family: Garamond, serif;
}

img {
    height: 100px;
    width: 300px;
    border: 1px solid #4682b4
    
a {
    color: #cc0000;
    text-decoration: none;
}

#5

From what I see I linked the CSS file just fine and everything works except for the link I'm supposed to style.


#6

you forgot to close

img {
    height: 100px;
    width: 300px;
    border: 1px solid #4682b4

#7

So it is indeed a careless mistake. Corrected it right away and it works !

Loads of thanks :+1: