Off-Platform Project: Boss Machine Starting Code Doesn't Work?

Hi guys, for the Off-Platform Project: Boss Machine, I think the starting code is incorrect/outdated.

I’ve tried running npm install multiple times and even tried other people’s solution codes but it still doesn’t work. I believe it’s because the code is probably outdated. However, I’m not quite sure.

Has it worked for anyone recently? Please help.

Hi Vishal,
I recently solved this exercise.
What exactly doesn’t work for you? what happens when you run npm install that makes you think the code doesn’t work?

My solution: GitHub - SimonSaban/project-4-boss-machine

I have this issue too. npm install gives this error:

npm ERR! code ERESOLVE
npm ERR! ERESOLVE unable to resolve dependency tree
npm ERR! 
npm ERR! While resolving: build-apis-boss-machine@1.0.0
npm ERR! Found: redux@3.7.2
npm ERR! node_modules/redux
npm ERR!   dev redux@"^3.7.2" from the root project
npm ERR! 
npm ERR! Could not resolve dependency:
npm ERR! peer redux@"^4" from redux-thunk@2.4.1
npm ERR! node_modules/redux-thunk
npm ERR!   dev redux-thunk@"^2.2.0" from the root project
npm ERR! 
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force, or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR! 

Hi Adam,

My npm install generated a similar error when I first run it. I then followed the suggestion to rerun the command with --force or --legacy-peer-deps, and it worked for me.
Have you tried that?

That didn’t work for me but I was told to downgrade node so that I could run it. In the end I just worked on the project without the live feedback.

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.