Node JS blocked by Malwarebytes Ransomware. Help Resolve?

In the Web Development course, I’ve reached section 10 in which we are adding the Git Bash command line and Node JS to our local environment.

These loaded nicely on my Laptop and PC.

However on my PC
Malwarebytes’ ransomware blocks my Git Bash command line Node JS commands. I get this error

$ node -v
Error creating winpty: ConnectNamedPipe failed: Windows error 232

When I turn off the Malwarebytes ransomware, the error resolves. And, of course, I can proceed. However, running without one’s ransomware seems dangerous. Right?

I added the git bash app “C:\Program Files\Git\git-bash.exe” file and the Node JS App “C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Node.js” both to the “allowed” list of Malware v4.0.4 and that didn’t help.

Since it works on my laptop and not on my PC, there must be a solution. Does anyone know if there is a known solution to running Node JS in the Git Bash command line WITH Malwarebytes Ransomware running?

Can’t give you a definite answer but I suspect your permissions are not covering everything that needs to be allowed.

gratitude for the input. I suspect you are correct. Any advice on what “needs” to be allowed? Super grateful.

Wish I could help. We’ll need someone who has completed this course AND has the software you have, or something similar that requires the same permissions. Sorry to leave you hanging.

@ionatan, @appylpye, is this something you are familiar with?

Here’s how you run a program:
Place an executable file somewhere in your file system.
Ask your operating system to execute that file.

Anything being done on top of that is only because somebody wants money. Raze the rest to the ground.

Oversimplified, unhelpful, but certainly funny. LOL.

Is it?
You’ve got this so-called anti-malware program behaving like malware.
You’ve got git bash in there and a work-around for running node in it, even though you could directly ask windows to run node.
I’d count windows among the things that ought to be razed to the ground but I realize it isn’t easily replaced (and that has a lot to do with microsoft’s lock-in strategy, making it difficult for people to use other things, which is one reason why it shouldn’t be used)

If you cut out a bunch of things between you and what you’re doing, suddenly you’re in a position to reason about what’s going on. If you don’t, then you’re dealing with a stack of commercial software and workarounds which amounts to being more complicated than the original task itself.

1 Like

You could at the very least cut out git bash and winpty
Run node from windows instead.
How does one ask windows to execute a file?
Click the file presumably. Or use cmd.exe/powershell, or the run dialogue box.

The problem is in adding a bunch of layers that you’re not in control of.

Spot on suggestion… A must.

ionatan and mtf,
Thanks for all the help. The key here is remembering I’m new, ah, like first class ever new. So, the “layers” removal certainly makes sense from a conceptual standpoint. I’ll man up and try to do that. But, I’m nowhere in the ballpark of your level of understanding of programming and coding. So, even the concepts you each consider “simple” may still have me scratching my head and running back here for your additional words of wisdom.
Gratitude all around.

FYI - while I’m not experienced enough to trust myself with running an executable file with my windows OS, I can certainly just shut down the Malwarebytes to “work around” it. Hence, I’ll venture out from shore but not so far that I can’t see land. I know it’s not as cool as you seasoned submariners could confidently pull off. But, at least I’m off the shore and sailing forward.

Well, one of us, anyway. Can you guess which one?

You’re welcome, all the same for what little help I may have been.

While not directly related to this, I found this post while searching for a fix for intellij with the same issue. A fix for this is to add the folder for the application to the Allow list in Malwarebytes

Settings -> Allow List -> Add -> File or Folder -> Select Folder -> [folder where application exists] should solve the issue. It did for Intellij which was trying to start winpty.exe

Hope it helps!

Thanks for your thoughts. Gratitudes.