Need help with "positioning!" | 2. Taking up space


#1

I have spoken to a couple advisors, they agreed that there was a glitch or bug, so I could never pass this section...

Here's my code:

div {
height: 50px;
width: 100px;
border: 2px solid black;
border-radius: 5px;
/*Add your CSS here!*/
display: block;
}
#one {
background-color: #FF0000;
}
#two {
background-color: #0000FF;
}
#three {
background-color: #FFD700;
}
#four {
background-color: #308014;
}

Whatever I do, it always says "Oops, try again." Many people here have the same problem,
when is this going to be fixed!!??

Please!


#2

Can you paste in your HTML and link of the lesson

This is a course that has been created years back, its not being updated at the moment. We hope for a new HTML & CSS course in the near future :slight_smile:

If you know HTML & CSS then your should try - Make a Website


#3

Thanks for the response, here's the link: https://gist.github.com/721caacd639eabda55b0dc1ed21d53f3

https://www.codecademy.com/en/courses/web-beginner-en-6merh/0/2?curriculum_id=50579fb998b470000202dc8b

I just really wanted to finish that as that's the only thing left in my course. My html & css course is 99%.....


#4

What you need to do is make sure all the lessons have a tick

On the section that has a missing % go and press save and submit to go through each or the last lesson of the section, it normally solves the problem


#5

Thanks for replying

Yes, in my case, section 2 in the 'positioning' lesson was in checked. I went in there and followed the instruction, it wouldn't let me pass. Whenever I submit, it always shows "Oops, try again.".

I have used the help from a couple advisors thru online chat and they couldn't figure out why it wouldn't let me pass. It didn't work for them either. They used their version of codes and didn't work either.

(My code is shown in the first post)

Is there a way anyone can check on this? Or is it a difficult fix?


#6

Hhmm weird I pass with no error, tried different browsers and accounts.. Try switching browsers.. Try Reset lesson and paste in again.

I don't have access to do any changes Codecademy's staff is working on a few new courses including HTML & CSS hopefully released in a few months


#7

I switched around all the browsers but it didn't work. I happened to update my mac after all these, and it magically worked!

thanks for the help tho! :slight_smile: