Need help with Deploy a Website on 5/7


#1

I can't get past the first question git add .

When I submit git commit -m "Save my work" I get this error:
fatal: Not a git repository (or any of the parent directories): .git


#2

are you sure you are in the right working directory? (pwd to check which directory you are in)

If so, initialize a git repository with git init, then add the files to the staging area (git add and finally commit (git commit)


#3

I'm in the "/home/ccuser/workspace/daw" directory.

When I cd into personal-website I get an error: No such file or directory.


#4

you are in the right directory, just initialize a git repository.


#5

Ok so I've done this:

git init
git add .
git commit -m "Save my work"

Now I get this:
[master (root-commit) 7745d11] Save my work
1 file changed, 0 insertions(+), 0 deletions(-)
create mode 100644 .cc

The question wont turn green


#6

this sucks, there are no files. lets create a file:

echo "why are the no files" > file.txt

now add again, and commit


#7

Still no luck so I've tried this:

touch file.txt
git init
git add file.txt
git commit -m "Save my work"

still nothing...


#8

use git add ., it will add all the files in the current directory

Which step are you stuck on? which one is not checking off? screenshot maybe?


#9


#10

the git init was only needed once, it looks fine. I will ask another moderator, i tried everything i can think of, you can maybe try a different browser, after so many submits cached data might be send


#11

seems you are in the wrong directory, go to personal_website using cd.

if not working can you show a print screen of the ls command?


#12

ls wont bring up anything. And cd personal-website won't work.


#13

make the directory:

mkdir personal_website

be sure to use an underscore.

then initialize a git repository:

git init

add a file, add to the staging area, make a commit, see if it works


#14

generate the directory with jekyll (you must have skipped that step, or spelled it differently, or have since removed it, or there were pixies around deleting it)


#15

I have gone back to the previous exercise where I create the personal-website directory. The exercises that follow after I create the directory return an error. See the screenshot. Is there any way to reset this exercise? It looks like a bug


#16

You don't need to revisit previous exercises (except for finding out what to do)

$ cd ~/workspace/daw
$ jekyll new personal-website
$ cd personal-website
$ git init
$ git add .
$ git commit -m 'whatever the commit message is supposed to be'

#17

Thanks it finally worked. Your a life saver!


#18

#19

What were you doing differently from that?
In my mind that's a single action (create a repository containing a skeleton jekyll site)

Figure out where you went wrong and how you could have written those commands instead. That's the only thing that matters
(no point trying to memorize what to type, it's all about figuring out what to type)


#20