[N/A] Unable to connect to codecademy

Hello people.
Whenever I start a new course here on the website, I receive a message “UNABLE DO CONNECT DO CODECADEMY”.
This is happening at least in three of the courses I would like to see during this quarantine: Learn SQL, Python 2 and PHP.
I’ve tried everything, I went to the help page to check if the site is undergoing maintenance, I checked my connection, I cleared the browser history and cookies but nothing resolved.

Hello @thiago_sm, welcome to the forums. What browser are you using? I will invite @thepitycoder to take a look at this. Thanks for reporting it!

Hello @codeneutrino !
I’m using Chrome version 81.0.4044.129 (64-bit) and I checked it is up to date. I also tried with Microsoft Edge and the latest version of Firefox, it always happens the same.

Sometimes ‘unable to connect to Codecademy’ happens to me. When you leave the tab and do something else and go back to the tab, it will show that error. But for me, you just have to click the screen for it to connect again.

3 Likes

Hi @thiago_sm

This happens occasionally, and usually resolves itself after a short while.

In the meantime, can you please try the following troubleshooting steps and see whether they resolve your problem? Thanks.

1 Like

Hello @thepitycoder ! In my case the problem has existed for a few days.

I’ve tried several times to reload the page, but it didn’t work;
Disable the windows firewall;
I tried to use another browser / computer;
I do not use the proxy service and any type of application blocker;
Connection test (Cable):
*6ms ping
*31 mb download
*16 mb upload;
I have already cleared cookies, cache and browser history;
Browser zoom is disabled (0%);
I disabled all extensions;
And nothing works, I open the lessons and I can’t click on anything, and the message at the top continues (Codecademy’s Unable to connect).
Is it possible that my internet server is blocking something?

Hey @thepitycoder and @codeneutrino
I just tried using another computer with linux / firefox without success.
I’m starting to suspect that it must be my network.
is there how to test if my network or server is blocking something?

Hello @codeneutrino, @animatedcoder and @thepitycoder!

This morning I tried again to enter courses and new ones but the same problem always happened.
So I tried to create a new account with another email address and it worked normally!
My account was in trouble!
Thank you very much for your help!
I will log in again with the problem account to give this topic as closed. Thank you so much again!

Hi there.

Glad to hear you got to the bottom of it, but I’m not sure why it would be an account specific thing.

Is this account (thiago_sm) the one that was having the problem, or the new one? :slight_smile:

Helo.
It was this @thiago_sm account that was in trouble. it was an old yahoo account.
So I made a new account using another email and it worked normally.

1 Like

Hi, sorry I can’t see how I can start a new topic, but hoping you can help? I have tried loading the courses on both my ipad and mac mini on both safari and chrome, but as soon as I hit ‘run’ then the programme stalls.

I thought perhaps I was doing a code wrong, but it has done it on 3 different lessons so far!

Hello @stephwillisuk, welcome to the forums! Have you read the above posts? You should check your network, and also the troubleshooting tips:


Also, if you’re doing loops, check to make sure you haven’t found yourself in an infinite loop.

1 Like