My lesson progress is lost


#1

I had completed 52% in python but the progress is showing 0% now

need help


#2

this was announced a long time ago in the blog:

https://www.codecademy.com/blog/important-changes-to-codecademy-courses

alongside the blog, pretty sure they also send an email saying that the course will be updated to the new enviroment, and that progress will be affected


#3

Hi @stetim94,
I am also in the progress of learning Python, and then I wanted to proceed, and then I saw a link: Reset my progress
which wasn’t there a week ago.
I know that the Python course has been updated, so maybe it is therefore.
Do you recommend that I reset my progress in order to keep myself updated on Python?

Regards,
Vicedivic


#4

the new enviroment allows for an entire course reset, where the old enviroment didn’t

Isn’t your progress already affected? It should be set back to zero

If you still worked on it last week, it should be fine, you can just progress. My progress has been reset, i am retaking the course now, so far i only seen minor changes (change in a variable name or something), so, i think its fine to just progress where you left off (if possible)


#5

I didn’t work on it last week, just to mention something that was before yesterday, where the course changed (tue aug 1). It is at least a month ago or something


#6

since I have worked on it


#7

So ideally , from yesterday the course got reset and i need to start from 0%


#8

your choice if you want to reset, i can’t tell you what to do :wink: If you feel like you could use redoing the course, you shuold

yep, i am afraid that is the case


#9

Then I remake it. I just wanted some support from others :wink:


#10

The “Reset my progress” button does not work! When I click “Reset my progress”, answer OK in the popup, and reloads the page it hasn’t deleted my progress! It still says “Resume (66%)”. How can I delete my progress if that button does not work?


#11

But it has actually deleted my code. Think it is a bug that it doesn’t change the progress overview when it deletes the progress


#12

I’m also sitting at 66% after “reset my progress”. I was trying to work on “Student Becomes the Teacher” section and kept getting “4/script.py has been moved. This will cause problems with this exercise, please move 4/script.py back to its original location, or reset your files”. I didn’t touch that .phy and don’t know where it is. And resetting files clears out the editor window and I can’t enter anything. Already reported the error. Also seems like running the code isn’t working.


#14