My code won't work on CSS lesson 26


#1

I checked my coding again and again, but each time I submit it is telling me that I haven't set my text-decoration to none. But I have! I entered the following, as guided:

a {
text-decoration: none;
color: #cc0000; }

I double checked my link as well, which appears. But when I put that in my stylesheet, the preview doesn't change at all. Is it a bug?


#2

I've also tried switching browsers, I've used Chrome and Safari so far and still the same issue.


#3

sure your link to stylesheet is correct? can i see your full html + css code? use the following steps to make html code visible:


#4
<!DOCTYPE html>
<html>
	<head>
	    <link type="text/css" rel="stylesheet" href="stylesheet.css" />
		<title>Result</title>
	</head>
	<body>
	    <h1>Header</h1>
	    <p>Filler paragraph</p>
	    <img src="https://40.media.tumblr.com/9f4dd0109a8a7f620aa3d9b0e32db759/tumblr_nw5n2uLXbc1qdx3xvo1_500.jpg" />
	    <a href="https://www.google.com/">Google this!</a>
	</body>
</html>

#5

If your css selectors have all the closing curly bracket (}) you hit a glitch, try a different browser as work-around. Just in case, can see all your css code?

Your html code is fine


#6
h1 {
    font-family: Verdana, sans-serif;
    color: #576D94
}

p {
    font-size: 18px;
    color: #4A4943;
    font-family: Garamond, serif;
}

img {
    height: 100px;
    width: 300px;
    border: 1px solid #4682b4

a {
text-decoration: none;
color: #cc0000;
}

I'm using a Mac and so far ive hit the glitch on chrome and safari. If firefox doesn't work, I'm going to borrow a Windows laptop and see if I can get around the glitch on that.


#7

What i already suspected, your img css selector is missing its closing curly bracket (})


#8

Wow, I must have overlooked it while trying to figure out what I did wrong, especially since I saw that section had a glitch previously. Thank you!


#9

You're are welcome, good you managed to pass


#10

i was stuck there for quite some time, but then i put the link to header, glad i managed to do that :smiley:
so now the link is in 2 places, body and head.


#11

i have stucked hier for 3 weeks, in lesson 25 and 26 css ..what is wrong with that


#12

Well, you could start by posting your html + css code and ensure your browser zoom is set to 100% (ctrl + 0 or cmd + 0 for mac), really useful in exercise 25


#14

<!DOCTYPE html>
<html>
	<head>
	    <linke type="text/css" rel="stylesheet" href="stylesheet.css"/>
	    </link>
		<title>Result</title>
	</head>
	<body>
	    <h1> header </h1>
	    <p> paragragh </p>
	    <img src="https://40.media.tumblr.com/9f4dd0109a8a7f620aa3d9b0e32db759/tumblr_nw5n2uLXbc1qdx3xvo1_500.jpg"/>
	    <a href="https://www.google.com/"> google that! </a>
	    
   </body>
</html>

#15

And your css code?

for next time, use one of the two following options to make your code/indent is visible:

select your code and press ctrl + shift + c (or cmd + shift + c if you use a mac)

if this instructions are unclear, you can also insert 3 backticks before and after your code, like so:

```
<p>visible</p>
```

the backtick is located above the tab key on your keyboard


#16
h1 {
    font-family : Verdana,sans-serif;
    color : #576D94;
}
p {
    font-size : 18px;
    color : #4A4943;
    font-family:Garamond,serif;
}
img {
    height:100px;
    width:300px;
    border:1px solid #4682b4;
}
a {
    text-decorationnone;
    color#cc0000;
}

#17

the problem is here:

<linke

it should be:

<link

#18

woooow ...that was awsome ..you did it ,thanks man ,,, i shoud see a eye doctor soon


#19

This worked for me! Thank you so much