Movies I

i need help !

1 Like

Hi Imageailin,

Could you try refreshing the page and let me know if that lets you pass?

Your routes.rb code looks fine :slight_smile:

1 Like

The code looks fine, but could it be the problem that you have not defined the index action in the Movies controller?

1 Like

how would you define the index action in the controller?

1 Like

I just defined like this and it worked for me:
def index
end

1 Like

Hi. I’m having trouble with the first step on this exercise. When I typed in “rails generate controller movies” an error came up saying that it was having trouble with the “movies.css.scss” script. I look at the script and nothing is there so I’m not sure what I should do about this. Please help ASAP I’m dying here D:

1 Like

@mutedhankie2755 Can you please post a screenshot of what you’re seeing in the terminal?

1 Like

I have the exact same problem as OP. My code in the routes.rb is identical, yet Codeacademy does not accept it as the correct answer for step 2.

get '/movies' => 'movies#index'

And this is what I get from Codeacademy:
config/application.rb to limit the frameworks that will be loaded.

EDIT:
It seems to be temporary bug. I tried restarting the excercise, put down the same code and it worked this time.

1 Like

@gigablaster30679

you need to use two ends

I have completely the same problem. I have an index action in Movies controller.
get ‘/movies’ => ‘movies#index’
doesn’t work. There is no error message from codecademy. I can’t go to next step in the exercise.
Could someone help, please.

@matocica Please create a new topic with your full code and a link to the exercise you’re on so we can help you.

Hi zystvan,
I did all you requested.
Thank you for your effort.

1 Like