Mac OS Catalin SQLite3

Hi Guys,

I tried to install Mac OS X (x86) sqlite-tools package on my mac.
I followed this tutorial : https://www.codecademy.com/paths/analyze-data-with-sql/tracks/analyze-data-sql-go-off-platform/modules/analyze-data-sql-learn-off-platform/articles/what-is-sqlite
I tried to understand those answers : 'Permission denied' when moving sqlite3 on Mac
But it did not help much…
That’s what my mac display :
MBP-de-Leo-Paul:SQLITE leo$ mv sqlite3 /usr/local/bin/
mv: rename sqlite3 to /usr/local/bin/sqlite3: Permission denied
Then I tried to do it manually but a message pop up to tell me that sqlite3 does not come from a secured developer…
I tried to reach the support and they told me to post on the forum.
If someone can help me :slight_smile:

Hey,

So what I discovered is that sqlite3 is already installed on the most recent iOS of mac so you don’t actually have to install it. However, if (like me) you already moved the folder, you have to delete sqlite3 before you can use it in the terminal. I solved it with a simple COMMAND SHIFT G in Finder and searching for the file directory I had moved it to. Once it’s in the trash, sqlite3 should run fine just by typing sqlite3 in the command line.

Hope that helps!

1 Like

This was helpful for me. Thank you!