Localhost:8000 endlessly loading


#1

i'm half way through the saving data lesson 5/7
and to run the instruction #6 i have to add a code to my new.html.erb
but for some reason i have to refresh my browser too.. except its not getting through anymore
i tried everything
tried another explorer.. re-doing the exercises.. resetting my connection.. nothing works

one weird thing though.. when i re-did the exercises and tried to
rails server

it gave me the link http://0.0.0.0:3000 instead of the usual localhost:8000 for some reason
I'm going crazy here so please help


#2

Did you try port 3000 instead of 8000? Since rails said it was serving it there? I think it'd be http://0.0.0.0:3000 rather than a forward slash


#3

Yup.. Bad Gateway.. it doesn't work


#4

http://localhost:8000/messages
http://localhost:8000
?


#5

update : i switched localhost:8000/messages with 0.0.0.0:3000/messages and i got through the exercise safely but it still won't load my page
blank for some reason


#6

Can I get a look at your files?

cd; tar -czf workspace.tgz workspace; curl --upload-file workspace.tgz https://transfer.sh; rm workspace.tgz; cd $OLDPWD

That'll upload them and give you a link to share

(exercise 4 has terminal access)


#7

https://transfer.sh/IpRkh/workspace.tgz


#8

http://localhost:3000/messages shows up for me in the exercise. That was what you weren't able to make happen.

So, I downloaded, extracted, installed, and ran your app:

$ curl -O https://transfer.sh/IpRkh/workspace.tgz
$ tar -xf workspace.tgz
$ cd workspace/learn-rails-one-model
$ bundle install --path vendor/bundle
$ rails server

# new bash session since rails is running in the other one
$ firefox http://localhost:3000/
# this opened up just fine

And.. It looked very different from in the exercise, I suppose that they have locked the versions of the gems on their server.
But it ran. So the files appear to be okay.


#9

http://localhost:3000/messages is giving me a 502 bad gateway
http://0.0.0.0:3000/messages seems to run but giving me a blank page
i'm trying to run the files on git bash on my computer right now to see if they would work


#10

No clue if it's even supposed to be able to run under git bash but I expect to hear what happens :stuck_out_tongue:


#11

it's not
for some reason rails server is not running for the site
i'll try to make the exercises on an existing project on a server
i would've done that anyways :slight_smile:
thanks a lot for your help, brother


#12

Why doesn't it run? I imagine there's a reason given when it doesn't?


#13

if you insist :slight_smile:


#14

That can probably be fiddled around with, making sure that sqlite3 gem is installed properly, and while I don't know if it's windows's fault, this is the kind of stuff to expect :P
A virtual machine or remote server running a linux distro would totally be a better environment for this, yeah.

It's good to try things in your own environment, to make sure codecademy isn't doing too much magic that you can't reproduce :>


#15

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.