Local Host 8000 Not Found Error


#1

Getting a "Not Found" error when I try to access the server at http://localhost:8000 on 'Hello Rails'. Is it Codecademy or is it me?


#2

Hi @chrisbclark,

This isn't just you. Please report it to the Codecademy staff through the form just beneath the instructions on the left.

Sorry for the inconvenience! It should be back up soon.


#3

No problem! Wanted to be sure I was messing up on Lesson #1. :wink:


#4

i have got same problem too. Is your fixed yet?


#5

same here. localhost page not found....help!


#6

Getting the same error, and this issue in the run box:

/home/ccuser/.gem/ruby/2.3.0/gems/activesupport-4.1.1/lib/active_support/values/time_zone.rb:285: warning: circular argument reference - now


#7

I gave up. Started doing Rails for Zombies at Code School.


#8

@zystvan, any word on if or when this will be resolved? Thanks.


#9

@h8windows Unfortunately not just yet, but you could try this workaround: https://discuss.codecademy.com/t/pages-controller-rb-not-in-folder/84291/12?u=zystvan


#10

Hi all! Heres the solution:

first of all, the rails new mysite isnt making everthing necessary to the system complete functioning. So, you all should reset the exercise (in need help box at bottom right corner) .

go rails new mysite and then its necessary to add thes 2 lines at the final of GEMFILE txt in root directory:

gem 'tzinfo'
gem 'tzinfo-data'

(RUN)

Only after that, do the bundle instal process.

Here´s another trick: the pages_controller was generated.. but is'nt visible yet. Just reload the page and voilá, there is the pages_controller.rb file!

After that, proceed with the instructions and have fun!

XX


#11

Not helpful for described problem. Still not found


#12

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.