Lingua Franca - An Offline Project

Hi!
I got stuck at Task 16 of Command Line Offline Project.
My terminal shows:
sed: 1: "africa/afrihili.txt": command a expects \ followed by text
after typing
sed -i 's/Lingua-Franca/Lingua Franca/g' */*.txt
Anyone knows what I am doing wrong?

Exercise: https://www.codecademy.com/courses/learn-the-command-line/articles/command-line-offline-project

I have the same problem. Do you use a Mac too?
I have found that "sed command with -i option failing on Mac "
StackOverfow Solution says “when you use -i an extension for the backup files is required” . I tried this:
sed -i'.bak' 's/Lingua-Franca/Lingua Franca/g' */*.txt
and it worked correctly

1 Like

Yes, I use Mac. I managed to finish the project. Yet I don’t remember if I used -i or -e. Maybe both options works.

Hi Zarlana and sylwiaaderek68329377,

I am limping through the “Lingua Franca - An Offline Project” and am completely stuck on Task 16. I am using a Mac. My terminal showed the same … “command a expects \ followed by text” jargon which I totally am clueless about. I copied and pasted Zarlana’s solution with the .bak … but what?! How was I supposed to know to do that?! So confused here…

Hi @thevizslacoder,

did you try sed -e ?

I’ve got the same problem as in the first message.
I tried ‘sed -e’ and it returned a long list that includes strings from all files, names of all files.
Adding of ‘.bak’ helped but I got duplicates of every file.