Lesson 9/9 weird error


#1



    "name": "Lloyd",
    "homework": [90.0, 97.0, 75.0, 92.0],
    "quizzes": [88.0, 40.0, 94.0],
    "tests": [75.0, 90.0]
}
alice = {
    "name": "Alice",
    "homework": [100.0, 92.0, 98.0, 100.0],
    "quizzes": [82.0, 83.0, 91.0],
    "tests": [89.0, 97.0]
}
tyler = {
    "name": "Tyler",
    "homework": [0.0, 87.0, 75.0, 22.0],
    "quizzes": [0.0, 75.0, 78.0],
    "tests": [100.0, 100.0]

def average(numbers):
   total = float(sum(numbers))
   total = total / float(len(numbers))
   return total
   
   
def get_average(student):
    homework = average(student["homework"])
    quiz = average(student["quizzes"])
    test = average(student["tests"])
    return homework * 0.1 + quiz * 0.3 + test * 0.6
    
def get_letter_grade(score):
    if score >= 90:
        return "A"
    elif score >= 80:
        return "B"
    elif score >= 70 :
        return "C"
    elif score >= 60 :
        return "D"
    else:
        return "F"
    print get_letter_grade(get_average(lloyd))

students = [lloyd, alice, tyler]   
def get_class_average(students):
    results = []
for students in students:
    results.append(students get_average(student))
return average(results)

print get_class_average(students)
print get_letter_grade(get_class_average(students))

   





The error I'm getting is: "Oops, try again. One of the following is missing or broken when we tried to use it: alice, lloyd, tyler, students, get_class_average, get_letter_grade"

however, the weird part of this is that my code is also throwing me this error: "File "python", line 19
def average(numbers):
^
SyntaxError: invalid syntax"

which is quite on because it started failing on lesson 8/9 and 9/9 anyone got any fixes or find something I'm do wrong? Thanks.


#2


i think this is wrong indentation ?


#3

Fixed it, however, this doesn't solve the original problem I've noticed that my code seems to believe "def" isn't an unknown syntax I tried deleting average and it gave me the same error but for the one below average.


#4

Missing a closing brackets, or whatever the name is, in the dictionary tyler.
It should be this:

tyle = {
#Whatever code in here
}

Usually whenever there's a syntax mistake like that, it's the line above the one it's current being shown as the error.


#5

I reset the code and it worked normally, seemed to have been a weird bug.

EDIT no you were right, I went to 8/9 which also had the same problem and it seems that I deleted tylers bracket by accident, thanks for the help.


#6

I think for students in students should be student in students


#7

Yeah , you are right ( i miss that ) (y)


#8

Yep, fixed all of that, the problem was however something different which has been solved.


#9

It is just a weird bug, my code worked perfect earlier when I was going to try and help but had some errors afterwards haha!
Crazy, I've seen tons of people asking the same question