Lesson 7: Column Headings (HELP, DRIVING ME NUTS!)


#1

I keep getting the error: "Make sure you have successfully entered into the first header 'favorite Monster' (without the quotes)". What am I missing? Here's my code below:




<body>

    <table border="1px">
        <thead>
               <tr>
                     <th>favorite Monster</th>
                     <th>Birth Year</th>
               </tr>
        </thead>
        <tbody>
            <tr>
                <td>King Kong</td>
                <td>1933</td>     
            </tr>

            <tr>
                <td>Drácula</td>
                <td>1897</td>
            </tr>

            <tr>
                <td>El hombre lobo</td>
                <td>1941</td>
            </tr>
        </tbody>
    </table>

</body>


#2

Not sure why the instructions in my Lesson 7 don't jive with the above picture, but I got it to pass with this...

            <thead>
                <tr>
                    <th>Famous Monster</th>
                    <th>Birth Year</th>     
                </tr>
            </thead>

#3

Weird. I switched it up as per your example. Still got the same error code. Not sure what to do now..





#4

Is that picture showing how you actually coded the tags? By rights, they should not have any whitespace...

< html >

should be,

<html>

as with all the other tags. The browser might not care, but the SCT might.


#5

I thought so too. However, when I type , it automatically turns itself to < html >...


#6

That sounds weird. I've never seen such behavior. What OS/browser are you using?


#7

Windows 7 on a Surface Pro 3 - Google Chrome


#8

Is it the same in all the HTML lessons? Your pasted code is normal, which is why I was suprised to see the picture. If is not having any effect, then I guess it is what it is.


#9

Yep,it's the same in all lessons. I guess i'll just move on to the next. Hope I'm not doing anything incorrectly.


#10

This is not the standard course you are doing, the instructions tell you to use all those spaces in all the html tags, if i look at the url of the exercise it looks different, here is the right one:

https://www.codecademy.com/en/courses/web-beginner-en-f8mcL/1/3?curriculum_id=50579fb998b470000202dc8b

#11

This URL takes me to lesson 8 and not 7.


#12

Then you go to lesson 7 from lesson 8? there is a navigation menu. But as you see, it is better


#13

Unfortunately, your solution was giving the same results. After continuing to play with it, I typed in the words in Spanish and it works. Go figure...


#14

Sorry, unlike @stetim94 and @mtf, I'm not fluent at HTML & CSS, this might be a stupid question... you tried refreshing, right? :confused:

Also, this is the URL I have:

https://www.codecademy.com/courses/web-beginner-en-f8mcL/1/2?curriculum_id=50579fb998b470000202dc8b

Sorry if I'm disrupting you guys or anything, just is that what the problem is confuses me ALOT.

Maybe a bug or something? But anyways, sorry if I disrupted you guys. :smiley:

P.S. I'm guessing that it isn't a refreshing problem because kpoleon, you have been talking with stetim and mtf for days, so it's just a thought. :smiley:


#15

Your ideas are welcome here without comparing yourself to @stetim94 or @mtf (me) and you need never apologize for expressing them. You can be at ease, and strengthen yourself through the interaction. Be yourself.