Lesson 2, step 2 "Model"


#1

I wonder if this is a bug:

Open the migration file in db/migrate/ for the messages table. The name of the migration file starts with the timestamp of when it was created. Inside the change method, add this line as line 4:

t.text :content

I do literally that and absolutely nothing happens. There's no progress in the terminal, I press Run and nothing changes. I don't get error messages, nothing. I don't know if I typed in the wrong code, or it's being buggy with me and not moving.

Should something happen when I type in the directions?

Thanks


#2

You should refresh your page, if your computer idles then connection may be lost.


#3

I tried, and I had to replace the original migration file, which is fine, that worked. That made step 1 get "checked" off and it proceeds to step 2, but still. Not budging.


#4

Did you run a migration?


#5

Yes it did, a new one.


#6

Could you post a link, so I can check my code for this lesson? :slightly_smiling:


#7

a link to the exact page I'm on?

https://www.codecademy.com/en/courses/learn-rails/lessons/one-model/exercises/one-model-model?action=lesson_resume


#8

I see... could you post a screenshot of your code in the migration table?


#9


#10

I would report this as a bug, my code is exactly the same as yours.

I hope your problem gets resolved soon. Good luck! :slightly_smiling:


#11

Thanks.
Glad to know I'm not going crazy.


#12

It's always good to know you aren't going completely insane. :slightly_smiling:


#13

I'm having the same issue. Very frustrating.


#14

Please click report a bug and do your best to explain what's happening.

This will speed up the process of fixing these issues.


#15

thank you for this. i thought i was legitimately losing my mind. It's taking a while to fix


#16

Ah good to know I'm not going crazy. There seems to be a old model file that I had to force out to actually create the model. In doing this though, you can't seem to get past step 2 for some reason. I already reported the bug. Hope it is fixed soon.


#17

The exact same thing is happening to me. I cannot progress past step two. This is so frustrating


#18

tried to delete the file by hand to generate another.. but the problem still :frowning:


#19

@all There's a known bug out right now which is preventing learners from completing exercises. Codecademy staff is working towards fixing it as fast as they can, so if you wait a little while and come back, you should be able to get past the exercise :slightly_smiling:


#20

It seems to be working now!! :smiley: