Lesson 11 bug?


#1

Is anyone else experiencing a bug in lesson 11? The code is correct (I've even put in it jsbin to check), but I keep getting an error:

"Oops, try again. It looks like you didn't set your div's opacity to 1. Check the example to in the instructions if you need help!"

I've put the code in jsbin and it works just fine:
(the difference being that instead of loading the jquery script my console in codeacademy loads up script.js)

http://jsbin.com/gobaze/2/edit?html,css,js,output


#3

Hi David,

What's the error message you're getting?
Thanks.


#4

I am getting the same thing

$(document).ready(function() {
$('div').mouseenter(function() {
$('div').fadeTo('fast',1);
});
});

It lets you go on but the div wont fade


#5

Never mind its not a bug xD I removed opacity on the button, I though 1 opacity was completely faded :stuck_out_tongue:


#6

Hi Zeke,

Error is as below.

Code is identical to what is in the jsbin link I posted earlier. Tried Firefox and Chrome. Seems that I'm not the only one encountering this issue. I've skipped the lesson for now and will return once this is fixed.

$(document).ready(function(){
$('div').mouseenter(function(){
$('div').fadeTo('fast', 1);
});
});


#7

@halfwitwanderer Looks to me like you need to move your mouse a little slower, since that seems to be what causes the SCT (Submission Correctness Test; code checker) to throw that error :)

mouse onto `<div>`
wait two seconds
mouse off of `<div>`
wait two seconds
go back to code editor

#8

@zystvan That's what I did. I saw the "wait 2 seconds" message at the bottom of the fullscreen. I even just left the mouse there for over 2 seconds and no dice. There are other threads reporting this and other variations of this bug:


#9

Yeah I'm having the same issue. I posted in another thread about it, looks like a few people are experiencing the same thing but haven't found any solutions yet.


#10

Remove the last semicolon, I had the same problem :confused:


#11

@halfwitwanderer I'm going to move this to the category for problems with Codecademy, maybe someone there will be able to help you better :)


#12

@bulbe Thanks I tried that - it didn't work. I also noticed this on your other thread. I'm glad this workaround worked for you, but it's kind of problematic for the code checker to accept wrong code over the correct code...I hope they fix this soon. Kind of annoying that even though I skipped ahead, every time I log on and continue my lesson it takes me straight to Lesson 11.

@zystvan Thank you for your prompt responses. I'm hope this gets fixed some time soon.