Learn Responsive Design Course is broken


#1

"No response received from web browser."
Every.
Single.
Exercise.

Also
"$expect is not defined"

This happen in all the exercises, even when I know I am writing the correct thing. I mean, some exercises only ask to change a value of 20px to 2em and so.

I am using Mozilla Firefox running on Win 7 64bits.

I made HTML & CSS course before and had no problem at all. This is becoming really frustrating because I can't continue to the next exercise without clicking the "Get Code" button.

Edit: Media Query Lesson seems to not have this issue.


#2

I get the same errors. Using Chrome, tried also in Edge, IE and FF - same result.


#3

Same error -- "no response received from web browser" -- using FF and Win 7 64bit.


#4

Same error here. All exercises ended with the "Get the code" option that put exact the same code than me.


#5

+1 Getting same error


#6

Hi, I got the same error. However, I was able to complete the tasks on my own. All I did, I tried to solve all tasks given in the instructions at once (even the ones that were not highlighted at the moment) and only then pressed "Run." It worked for me. But there is definitely something wrong with that.


#7

Same thing..................


#8

Hi,

I honestly am receiving the same data. I tried it on Google Chrome, Mozilla Firefox, Microsoft Edge, and Microsoft Internet Explorer receiving the same message "No response received from browser". I was not able to use Learn Responsive Design course and I was very ungrateful for that


#9

It's not just me then, I guess I will not be upgrading if this is what you get .


#10

The best thing to do is to try running it a few times. After two or three times of running it, it should give you a green check mark. First it should say No response received from web browser. Then it after it should say $expect is not defined. It does that for most lessons and I don't know why.


#11

It isn't in all the courses but upgrading it will definitely be a waste of your money


#12

Same problems using FF 54 Linux 64 bits


#13

Thanks for the tip! I will try this in case it happens in future lessons! :smiley:


#14

same here, tried in all browsers


#15

Seems to be working O/K now. :slight_smile:


#16

Hello All.
Everything works without errors in Yandex Browser.
Please try it


#17

I’m not seeing the web browser populate for my course using Chrome. In place I’m seeing a "k5l3brfcbul2t3fjpv1rso5ebvtr0nbbcl2i6g7eevpklobdeksg.codecademy.cloud’s server DNS address could not be found. " error.


#18

Same problem here((((((((


#19

Same here, also there is an error en exercise 4 and the images position, also %50 of width is too small for the text in blog post, it gives a too large margin.