Learn rails broadway generate controller Pages error


#1

excercise:

https://www.codecademy.com/courses/learn-rails/projects/learn-rails_broadway

rails new broadway
cd broadway
rails generate controller Pages

$ rails generate controller Pages
/home/ccuser/.gem/ruby/2.3.0/gems/activesupport-4.1.1/lib/active_support/values/time_zone.rb:285: warning: circular argument re
ference - now
/home/ccuser/.gem/ruby/2.3.0/gems/activerecord-4.1.1/lib/active_record/connection_adapters/connection_specification.rb:190:in rescue in spec': Specified 'sqlite3' for database adapter, but the gem is not loaded. Addgem ‘sqlite3’` to your Gemfile (and
ensure its version is at the minimum required by ActiveRecord). (Gem::LoadError)

then when i check the controllers path i do not see that Pages controller has been generated.


#2

forgot to mention that of course i did bundle install also.

rails -v shows rails 4.1.1


#3

Hi @devcoder25660,

Could you please post the contents of your Gemfile here?


#4

gem file below:

source 'https://rubygems.org'


# Bundle edge Rails instead: gem 'rails', github: 'rails/rails'
gem 'rails', '4.1.1'
# Use sqlite3 as the database for Active Record
gem 'sqlite3'
# Use SCSS for stylesheets
gem 'sass-rails', '~> 4.0.3'
# Use Uglifier as compressor for JavaScript assets
gem 'uglifier', '>= 1.3.0'
# Use CoffeeScript for .js.coffee assets and views
gem 'coffee-rails', '~> 4.0.0'
# See https://github.com/sstephenson/execjs#readme for more supported runtimes
# gem 'therubyracer',  platforms: :ruby

# Use jquery as the JavaScript library
gem 'jquery-rails'
# Turbolinks makes following links in your web application faster. Read more: https://github.com/rails/turbolinks
gem 'turbolinks'
# Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
gem 'jbuilder', '~> 2.0'
# bundle exec rake doc:rails generates the API under doc/api.
gem 'sdoc', '~> 0.4.0',          group: :doc

# Spring speeds up development by keeping your application running in the background. Read more: https://github.com/rails/spring
gem 'spring',        group: :development

# Use ActiveModel has_secure_password
# gem 'bcrypt', '~> 3.1.7'

# Use unicorn as the app server
# gem 'unicorn'

# Use Capistrano for deployment
# gem 'capistrano-rails', group: :development

# Use debugger
# gem 'debugger', group: [:development, :test]

#5

any response please?

I was hoping to use codeacademy pro to learn ruby and ruby on rails, but I’ve instead resorted to using a local dev environment to learn instead.

I cannot progress any further on these exercises because of these errors.

a workaround would be welcome


#6

Sorry, I wasn’t active on here yesterday and I had a few things I had to take care of this morning.

Try adding these lines to the Gemfile:

gem 'tzinfo'
gem 'tzinfo-data'

Then run bundle install in the terminal, and see if that makes the error go away.


#7

exact same error after adding

gem 'tzinfo'
gem 'tzinfo-data'

to Gemfile and running bundle install

are you able to reproduce the same error on that excercise?


#8

looks like I found a fix

I changed default sqlite entry in Gemfile from

gem 'sqlite3'

to

gem 'sqlite3', '~> 1.3.13'

then ran bundle update & bundle install again.

now rails generate controller Pages works as expected

thanks for your help any way


#9

This topic is solved.