Large amount of bugs in "Learn Ruby on Rails"

I couldn’t find the specific topic for " Learn Ruby on Rails" but i’ve been experiencing a lot of bugs with it over the past few hours.
i’ve finished the introduction to rails course and was planning to directly continue with “Learn Ruby on Rails”

As for the bugs i’ve encountered

When entering code in for example routes.db and then opening a different file it will sometimes copy the code from routes.db into (for example) a controller or view file completely replacing what was originally in there.

When pressing space, copy pasting something or attempting to type on a new line in section “saving data”. The console will instantly remove anything you type/paste and jump your cursor to the top of the file removing everything you attempt to type and preventing further progress (which is why im stuck)

Sometimes a file is opened and contains no code whatsoever forcing either a reset or memorising the code yourself and typing it 100% from scratch.

i’m not sure where these bugs came from but from what i’ve read so far others have experienced them as well.
i did force a couple of resets (bottom right) while following the course and also forced one while in the files editor so that may have something to do with it.
I’ve tried restarting the browser, the course itself and the pc but it’s not working.

I’ve gotten through the first part experiencing the same issues but i cannot continue any further because of the second bug i mentioned where it removes all my input.
Hopefully there is a temporary manual solution or a fix is deployed soon.

thank you for reading :slight_smile:

1 Like

Bumping …

I’ve had many problems in the last 12 hours with the Rails class with different bugs than yours.

Earlier this morning, I got to the point where I had no contents in my system period. There were NO commands available, not even “ls.” Just prior to that, the editor was running so slow, I couldn’t even select a file, let alone modify it. When I tried loading the modified web page in the built-in browser, it would just stall. I reported the bug, but growing impatient, I created a new login to get back to where I was.

The biggest problem right now is I’m Creating Message I lesson (5/7) and the web page won’t render no matter what I try, including refreshing the page, closing the browser, and logging out and back in. The spinner just goes and goes without stopping until it finally times out and I get a prompt asking if I’m still here.

Is it just me or is there a system issue?

1 Like

Hi, I have the same problem with Creating Message I lesson (5/7), could someone help us with this? Thanks in advance!

1 Like