Jupyter install/launch Failure

Hey there! I’ve installed Python 3.8 64-bit and Miniconda 3 64 bit. I selected to add a PATH during both installations, then attempted to install Jupyter through CMD. At the very end of the install it printed:

ImportError: DLL load failed while importing _win32sysloader: %1 is not a valid
Win32 applicatiodone

When I try to launch Jupyter Notebook from CMD, it fails and prints:

Can anyone help me understand how to fix this? I can’t move forward with my course until I get it sorted, and I’m too new to this to troubleshoot on my own.

Thank you!

Did you try using Anaconda Prompt instead of CMD?

I believe Anaconda Prompt comes with Miniconda now, and you can check by typing “Anaconda” in the search bar next to the Start menu and selecting Anaconda Prompt.

If you have this, try installing and running jupyter from there and let us know if it worked from there. You should see (base) in front of the prompt, which will indicate that your base conda environment is active. If you didn’t see that on your prompt last time, that may have been the issue.

Thanks for the response! I tried what you recommended in the Anaconda Prompt and this is what it spit out:

I think it is printing the same problem but I could be wrong?

Hmm…It looks like conda is trying to use two different versions of Python: the one installed in the miniconda3 folder and the one in the AppData\Roaming\Python\Python38 folder.

I’m not sure why this would happen, and I’ve never experienced it myself, but I think if you either remove the non-Miniconda python from your path or uninstall it, then you can try conda install jupyter and jupyter notebook from Anaconda Prompt and it should work in theory.

If you want to uninstall Python, you can just search for Python in the search bar and you should see an uninstall option:

1 Like

Solved! I uninstalled Python 3.8, Python Launcher, and deleted Python from the PATH. Found jupyter_notebook.exe in the miniconda PATH, ran it, and it opened!

Thank you for the help, I’m really excited to finally move on in the course!

1 Like

Glad that worked out for you - good luck on the rest of the course!

1 Like

This topic was automatically closed 41 days after the last reply. New replies are no longer allowed.