jQuery -- French -- Unable to pass exercise in French, but works in English

Hello there,

I either got the same “Oops, try again. Please follow the instructions on the Full Preview page to test your code.” error (can’t seem to reproduce it now) or another one which is “Oups, merci de réessayer. $e(…).a.cacher is not a function”. Now I get that my CC being in French surely is what causes the error, but if I change it to English, I lose all my progress. Any help from members or staff ?

In case I’m completely mistaken about what is going wrong, here is my code:

I tried with or without a semi-colon after (‘slow’), doesn’t change a thing. I also tried clicking slowly on Submit, click me & back to the editor, but nothing seems to work.

Thank you for your help,

Have a nice day :slightly_smiling:

@aloyzia_x Are you able to pass the exercise if you use a different browser?

No. Tried Firefox, Chrome, & Safari, and some won’t even load the page so no improvements :disappointed:

Exercise link for anyone who may want to try the exercise: https://www.codecademy.com/courses/web-beginner-en-GfjC6/1/2

@aloyzia_x I’ve moved this to the category for problems on Codecademy. Your code worked for me, even when I changed the site to French :confused: Would you mind posting a screenshot of what you’re seeing?

Of course not, here it is:

Not sure it’ll be much help, but !

For the records, I’m gonna try this at home (I’m at Uni rn), I don’t have much hope but if it changes anyting I’ll tell you !

Hm, I get the same thing. I think that if you indent your code the way they have it, you should get passed, though:

// works
$(document).ready(function() {
    $('button').click(function() {

// doesn't work
$(document).ready(function() {
$('button').click(function() {

Since both are the same aside from indentation, this is a bug with Codecademy. I’ll add the bug tag to this post.

Also - link for anyone else who may want to try the exercise: https://www.codecademy.com/fr/courses/web-beginner-fr-FR-w5vxj/1/2

Tried the new indented code (my own computer (different than yesterday), at my workplace (also different)) and it still didn’t work :confused:

As I said yesterday, I’m also gonna try at home (it’ll be the same computer as now), but I admit I’m running out of ideas.

Thank you very much for your help though

Since it works for me, I’m not really sure what to suggest :confused:
Please let me know if you get it working!

Hopefully the Codecademy team will be able to fix it soon :slight_smile:

Tried this on my personal computer at Uni, still haven’t tried at home though. But it looks like I’m not the only one, which somehow reassures me ! Problème 6/13 : étrange message d'erreur…