Javascript Promises(bash does't work when press check Work)

Hello everyone how are you doing today?

I have a problem with the bash with codecademy. Every time i finish all the code and they ask to check the work with node or npm i get this message as Error but the test is accept to the next lesson but i can’t check the work that i done. Here is example:

node app.js
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
node app.js
          cwd = process.cwd();

Error: ENOENT: no such file or directory, uv_cwd
    at Object.resolve (path.js:1142:25)
    at startup (bootstrap_node.js:129:32)
    at bootstrap_node.js:542:3

Can somebody explain to me why is this happening?

I apreciate and wish you a nice Day

from googling that error is saying that the directory you’re trying to run the script from got deleted somehow… Have you tried resetting your workspace / closing your codecademy session and opening a new one? You might lose your progress on the current exercise, I’m not sure, but getting the exercise served to you new might address this.

If that doesn’t fix it and this is a blocking issue for you from continuing on, you might consider posting this under Community > Support, too.


Other students have faced the same error over a fair period of time: Intermediate JavaScript Promises error

Restarting the bash terminal seems to be useful (as noted in the other thread).