Java Runtime Environment not working


#1

This is happening in all of my exercises.
The terminal does not work at all, it just says it has insufficient memory, error printed below.
Really would like to be able to code properly with this, but I can’t see what I’m printing.
Thank you

‘# There is insufficient memory for the Java Runtime Environment to continue.
’# Cannot create GC thread. Out of system resources.
’# An error report file with more information is saved as:
’# /home/ccuser/workspace/java-hello-java/hs_err_pid14.log


I don't understand this error message?
#2

I’m having the same issue as you. I’ve restarted and reinstalled Java but still having the same issue. I can’t figure it out or how to even find that error log location…


#3

I have same problem here. I was wondering what happened


#4

Anyone have any luck with troubleshooting this?


#5

Hi,

I have just finished the Data Structure module, however I had the same error while doing that. It definitely appeared recently, as last week everything run fine.

Cleared browser’s cache (Chrome), checked the memory, but without a luck. I’m working on W10, does anyone has a different OS and a browser to check it?

Regards,
Lukasz


#6

Same problem here, any solutions?


#7

Same here. It should be coming from their end.


#8

Same. It’s definately coming from their end. All we can do is wait.


#9

I feel better knowing that it is likely on their end. Guess I’ll start learning some Python in the meantime. Keep me posted if y’all hear anything.


#10

Same here! looks like their servers are down i guess


#11

Currently facing the same issue. I’m guessing it truly is a server-side issue. Hope we get a response soon.


#12

I too am having this issue, and I see a countless amount of others also experiencing it in the past 24 hours. Clearly server side. It seems the only option here is to wait it out.


#13

It happened to me too, working on HashMaps


#14

Was working in Java same issue, definitely serverside


#15

Yep. Happening my end too; must be their servers. I was getting worried that I’d have to restart a whole load of stuff haha. Hope this gets fixed soon!


#16

Just sent them a bug report and tweet about it!


#17


#18

Problem solved. Guess waiting helped after all. At least I don’t have this problem anymore.


#19

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.