.java file not saving if it's unable to compile in Codecademy's IDE?

I was working on the Deserted Island Playlist course when I encountered this. The .java file only updated when the code was able to compile. I discovered this because I made some changes to the code, but didn’t see any difference when I ran the .java file in the terminal. I tried to compiled it and saw that I had made a parsing error, which I fixed and saved it again. This time when I tried to run the file it had the updated code. I can’t guarantee it 100 %, but I’m fairly certain that I saw it run changes in the code when I clicked save, without compiling it first in the terminal.

My input in the terminal for running the file was “Java Filename”, and javac filename.java for compiling.
Is this because I’m running the compiled file with this command, and it auto-compiles when you click save or what is going on? Also, is this what I should expect when working with this in another IDE, or would it show that there was an error in executing the code if I wrote “Java Filename”?