Java course bugged

defining methods module in learn java is completely busted.

posting correct code returns failure, “view correct code” doesn’t load.

if you fork the code the store.class file looks like this

Look at the .java files, not the .class files.
Store.java would have the Java code it in.
(LE.java and Main.java) too)

do you mind taking a look at that module and see if its just acting this way for me?

still won’t accept the correct code and won’t load the view solution

here’s url

https://www.codecademy.com/courses/learn-java/lessons/learn-java-methods/exercises/defining-methods

1 Like

Ah, now the page won’t even load at all…
image

Not sure how to tag support, there used to be a chat support option.

this has been happening since yesterday, this page specifically is completely unresponsive.

cleared cookies etc etc even tried in a different browser and on a different computer

any ideas how to fix this would be appreciated, really could use the cert by tonight or this weekend at the latest

Apparently the java course had some updates very recently on May 2, 2024, so it might be related to it.

Have you tried resetting the exercise?
(From the Get Unstuck drop-down, select reset exercise).

I had completed this exercise in the past This is what I am currently seeing:

but I think that if I reset the exercise, it should probably work. Haven’t tried it though.

1 Like

Yep, I have tried resetting the exercise a few times, it still just returns the same signature error on your code and blanks out when clicking on view solution

And Just in case I am a complete knob, I am constructing the method as public void advertise() {

}

I just clicked the “Close dialog” button and it seems to be working for me (firefox). I can also view the solution.

There is a “report bugs” option in the drop-down, but I don’t know whether and how soon they will get back to you.
There is also a Help Center submit request option: https://help.codecademy.com/hc/en-us/requests/new

Perhaps go back one exercise and reset that exercise, and then delete all your history, cache, cookies. I don’t know why it isn’t working for you. I am using windows+firefox and can view the solution etc. without issue.

I have only tried on chrome and edge, I don’t have firefox installed

Thanks, I opened a support ticket and the dev team is currently working with me to fix this,

thanks for your suggestions everyone!

Hello, I am having an issue with the java course as well since Friday. Just curious if yours has been resolved yet? As I submitted a bug report on Friday night and it has not been fixed and I am unable to proceed in my java lessons because of this issue.

It has been resolved for me, are you still having the same problem?

1 Like

Tonight when I reset the workspace it worked when I redid the lesson! Resetting didn’t fix it previously. Glad it seems to be fixed now

woww i never knew that