It's Not Cheating—It's Debugging!


#1

https://www.codecademy.com/courses/learn-python/lessons/battleship/exercises/its-not-cheatingits-debugging?action=lesson_resume&link_content_target=interstitial_lesson

when i got to this exercise i got no code written at all, and even when I followed the instructions and click “Run” , it begins loading for a very long time without doing any thing (even though no message showed up to tell me that my code is incorrect)

finally when i tried to refresh the page and clicked rest i got this message in a white box:

Whoa there!

8/script.py has been moved. This will cause problems with this exercise, please move 8/script.py back to its original location, or reset your files
reset files ok

and either to click on “rest files” or “ok” but neither of them do anything.

print ship_row
print ship_col


#2

i’m waiting for answers


#3

I have this problem too. I tried to do it from Chrome and Firefox but it just keep loading


#4

triple that, hoping like you for an answere :slight_smile:


#5

Same here, I have tried reset under different browsers, IE, Chrome, Edge, Firefox and seems none of them work. Really hope this issue could be solved :frowning:


#6

Same here. I’ve tried earlier and thought it could be a server problem, but nothing changed. I also tried to do all exercises again, but It’s not a solution neither.

Any help?


#7

I am stuck too.
Not able to progress forward.
Did anyone find a solution to this?


#8

I am still stuck on that exercise and can’t proceed. Is there a way to skip that exercise at least?


#9

u can try to reset the code and click run for several times till a message appear to you:
stuck here
keep trying get code
when you click on “get code” you will be able to pass to the next exercise.


#10

Go to Get Help option on the right bottom corner of the page.

Then,click on I want to restart this exercise.

Then write your code.


#11

It Works!! Thanks! the code still has problems but you can use ‘Get code’ and press next


#12

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.