It's Dangerous to Go Alone! Take This


#1

Output is none, but codecademy says "Oops, try again. It looks like you do not have all the correct items in inventory["pocket"]." , and I do have all the correnct items in pocket I've checked it a few times. Is that a bug? Please help me.

inventory = {
    'gold' : 500,
    'pouch' : ['flint', 'twine', 'gemstone'], # Assigned a new list to 'pouch' key
    'backpack' : ['xylophone','dagger', 'bedroll','bread loaf']
}

# Adding a key 'burlap bag' and assigning a list to it
inventory['burlap bag'] = ['apple', 'small ruby', 'three-toed sloth']

# Sorting the list found under the key 'pouch'
inventory['pouch'].sort() 

inventory['pocket'] = ['seashell', 'strangeberry', 'lint']
inventory['backpack'].sort()
inventory['backpack'].remove('dagger')
inventory['gold'] = 500 + 50

#2

It's not a bug. Are you completely sure that you have 'strange berry' in the pocket? :slight_smile:


#3

I tried now and it worked. I didn't know that i could have a space between words so I've typed _ instead of space. So thank you :smiley:


#4

You're very welcome :slight_smile:

Object names can not include a space, but in the strings, you can write whatever you want :wink:


#5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.