Issues installing miniconda

I’m having some issues with miniconda. I just finished installing it, but when I type “conda list” in Git Bash, it returns “bash: conda: command not found”. Does anyone know what the issue may be?

By default, miniconda installs conda in either Cmd or Anaconda Prompt on Windows. If you haven’t gone out of your way to set it up for use in Git Bash, you won’t be able to.

When I try to use it it in Command Prompt, I get a similar error message:
‘conda’ is not recognized as an internal or external command,
operable program or batch file.

When I try to use it in Anaconda Powershell Prompt, I get:

I’ve had issues before with my username having a space in it. Could that be the issue? If so, do you know how I could fix it?

Do you have Anaconda Prompt installed or not? If you don’t, conda would have been installed in Cmd. If Cmd is telling you that ‘conda’ is not recognized as an internal or external command, operable program or batch file then either miniconda is not installed or it installed Anaconda Prompt, which is where it would be set up for default use.

The screenshot you sent is from Powershell, not Anaconda Prompt. Go to the search bar at the bottom of your screen and search Anaconda. It should pop up. If it doesn’t, you may want to try downloading and installing miniconda again. I don’t think your username should pose a problem here.

Thank you for the assistance. I tried using Anaconda Prompt (not Powershell) and it gave me the same response as Cmd. I can see all the files and folders for miniconda3, but the ‘conda’ command doesn’t seem to work. Is there an alternative command to use miniconda? When I setup Python, I couldn’t get it to work until I used ‘py’ instead of ‘python’ - is something similar going on?

Can you post a screenshot of your command and your error in Anaconda Prompt? You should never be getting an error saying that ‘conda is not a command’ with Anaconda Prompt.

Okay, here is the error message:

That’s very strange.

Try reinstalling miniconda, but this time check YES to the option that asks whether or not to prepend the conda prompt to your path.

@ajax0049860725,

Actually, it may have something to do with your username having a space.
I just found this on stack overflow: https://stackoverflow.com/questions/60789886/error-failed-to-create-temp-directory-c-users-user-appdata-local-temp-conda

You can try using the search bar at the bottom and searching for “environment variables” then open “Edit System Environment Variables”. Once you are there, click the Environment Variables button and look at your user variables. Under the TEMP and TMP ones, change the value to have quotes around your username.

2 Likes

Got it, thank you. I tried adding the quotes, but I still got the same error message. I’ll try uninstalling and reinstalling miniconda and add conda to my path when I reinstall it. I delete miniconda by just deleting the folder correct?

Instructions on uninstalling it here:
https://docs.conda.io/projects/conda/en/latest/user-guide/install/windows.html#uninstalling-conda

Actually, I think you were right - the space was the issue. I uninstalled and reinstalled (adding conda to my path), but it just threw a process failed error. I ended up changing my username to remove the space and now it works. Thanks for all the help!

1 Like

No problem! Glad you got it figured out!

1 Like